summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-07 18:17:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-07 18:17:29 +0000
commitcfd87ea448bbae5ca9633494e3c664e32de5ebf6 (patch)
tree5d5d8fa959d9acf5d03db86a64b78b4a3d50023d /dev-python/pyzmq
parentFixed MPI for openmpi (bug #354993, thanks Yang Zhang. Added a patch to fix o... (diff)
downloadgentoo-2-cfd87ea448bbae5ca9633494e3c664e32de5ebf6.tar.gz
gentoo-2-cfd87ea448bbae5ca9633494e3c664e32de5ebf6.tar.bz2
gentoo-2-cfd87ea448bbae5ca9633494e3c664e32de5ebf6.zip
Documentation still fails to build.
(Portage version: 2.2.0_alpha26_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/pyzmq-2.0.10.1.ebuild40
1 files changed, 27 insertions, 13 deletions
diff --git a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
index d9ef50d94fa4..f160e7fa04b3 100644
--- a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.4 2011/03/06 23:10:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.5 2011/03/07 18:17:29 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*:2.5"
@@ -17,12 +17,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE=""
+# IUSE="doc"
RDEPEND="net-libs/zeromq"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( >=dev-python/sphinx-0.6 )"
+DEPEND="${RDEPEND}"
+# doc? (
+# dev-python/setuptools
+# >=dev-python/sphinx-0.6
+# )
DOCS="README.rst"
PYTHON_MODNAME="zmq"
@@ -36,12 +39,22 @@ src_prepare() {
src_compile() {
distutils_src_compile
- if use doc; then
+
+ if false && use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
-# PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib.*)" emake html || die "Generation of documentation failed"
- PYTHONPATH=".." emake html || die "Generation of documentation failed"
- popd > /dev/null
+ if has_version ">=dev-python/sphinx-1.1"; then
+ # Sphinx 1.1 probably will support Python 3.
+ die "Untested environment. Ask Arfrever to update this code."
+ PYTHONPATH="$(ls -d build-$(PYTHON -f --ABI)/lib.*)" "$(PYTHON -f)" setupegg.py build_sphinx || die "Generation of documentation failed"
+ else
+ local sphinx_python_abi="$(PYTHON -2 --ABI)"
+ if [[ ! -d "build-${sphinx_python_abi}" ]]; then
+ "$(PYTHON -2)" setup.py build -b "build-${sphinx_python_abi}" || die "Building for Sphinx failed"
+ fi
+ pushd docs > /dev/null
+ PYTHONPATH="$(ls -d ../build-${sphinx_python_abi}/lib.*)" emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
fi
}
@@ -54,7 +67,8 @@ src_test() {
src_install() {
distutils_src_install
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
+
+# if use doc; then
+# dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+# fi
}