summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 16:59:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 16:59:42 +0000
commit234b541fb79ea78806801c08701cc5bc70a267d0 (patch)
tree8303796c2ea84e1ba51e38918edabb98808e79d8 /dev-python/rope
parent- ver bump to fix bug 263892 (diff)
downloadgentoo-2-234b541fb79ea78806801c08701cc5bc70a267d0.tar.gz
gentoo-2-234b541fb79ea78806801c08701cc5bc70a267d0.tar.bz2
gentoo-2-234b541fb79ea78806801c08701cc5bc70a267d0.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14200-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/ChangeLog6
-rw-r--r--dev-python/rope/rope-0.9.2.ebuild25
2 files changed, 23 insertions, 8 deletions
diff --git a/dev-python/rope/ChangeLog b/dev-python/rope/ChangeLog
index d56696ba9c7d..8cc74f170d1f 100644
--- a/dev-python/rope/ChangeLog
+++ b/dev-python/rope/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rope
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/ChangeLog,v 1.4 2009/09/04 17:40:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/ChangeLog,v 1.5 2009/09/05 16:59:42 arfrever Exp $
+
+ 05 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ rope-0.9.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*rope-0.9.2 (04 Sep 2009)
diff --git a/dev-python/rope/rope-0.9.2.ebuild b/dev-python/rope/rope-0.9.2.ebuild
index f2c529e9a629..97f93135ead9 100644
--- a/dev-python/rope/rope-0.9.2.ebuild
+++ b/dev-python/rope/rope-0.9.2.ebuild
@@ -1,25 +1,36 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/rope-0.9.2.ebuild,v 1.1 2009/09/04 17:40:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/rope-0.9.2.ebuild,v 1.2 2009/09/05 16:59:42 arfrever Exp $
-NEED_PYTHON=2.5
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Python refactoring library"
HOMEPAGE="http://rope.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib:." "$(PYTHON)" ropetest/__init__.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
docinto docs
dodoc docs/*.txt
}
-
-src_test() {
- PYTHONPATH="." ${python} ropetest/__init__.py
-}