summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-20 10:00:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-20 10:00:16 +0000
commit0498d5db9ad8657a500fd1468590d3d883b91d6c (patch)
tree9d21cdd240284c77572aee921b0a18d86212bcea /dev-python/rpy
parentVersion bump (diff)
downloadgentoo-2-0498d5db9ad8657a500fd1468590d3d883b91d6c.tar.gz
gentoo-2-0498d5db9ad8657a500fd1468590d3d883b91d6c.tar.bz2
gentoo-2-0498d5db9ad8657a500fd1468590d3d883b91d6c.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/ChangeLog7
-rw-r--r--dev-python/rpy/rpy-2.4.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index 2cb1cab8203c..685baad6bb93 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/rpy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.80 2014/06/24 01:58:44 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.81 2014/08/20 10:00:16 idella4 Exp $
+
+*rpy-2.4.3 (20 Aug 2014)
+
+ 20 Aug 2014; Ian Delaney <idella4@gentoo.org> +rpy-2.4.3.ebuild:
+ bump
*rpy-2.4.2 (24 Jun 2014)
diff --git a/dev-python/rpy/rpy-2.4.3.ebuild b/dev-python/rpy/rpy-2.4.3.ebuild
new file mode 100644
index 000000000000..85b83c19fef8
--- /dev/null
+++ b/dev-python/rpy/rpy-2.4.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-2.4.3.ebuild,v 1.1 2014/08/20 10:00:16 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pandas-0.13[${PYTHON_USEDEP}] )"
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' -v || die
+}