summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-07 08:33:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-07 08:33:02 +0000
commit93fa878c4020ac8d53999c1e12652aeb0a28fea2 (patch)
treee0b58e25e1772ea012092d22a4b912b40bf04002 /dev-python/rpy
parentFix gcc-4.3 build issues (bug #217755, thanks to Peter Alfredsen and Debian) (diff)
downloadgentoo-2-93fa878c4020ac8d53999c1e12652aeb0a28fea2.tar.gz
gentoo-2-93fa878c4020ac8d53999c1e12652aeb0a28fea2.tar.bz2
gentoo-2-93fa878c4020ac8d53999c1e12652aeb0a28fea2.zip
Patched for R >= 2.7, thanks dawe for his patch (bug #219522)
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/ChangeLog8
-rw-r--r--dev-python/rpy/files/rpy-1.0.2-rpymodule-R-2.7.patch14
-rw-r--r--dev-python/rpy/rpy-1.0.2-r1.ebuild55
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index 52d811c1ea3d..850e2ebc5e23 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rpy
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.21 2008/04/11 16:38:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.22 2008/05/07 08:33:02 bicatali Exp $
+
+*rpy-1.0.2-r1 (07 May 2008)
+
+ 07 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/rpy-1.0.2-rpymodule-R-2.7.patch, +rpy-1.0.2-r1.ebuild:
+ Patched for R >= 2.7, thanks dawe for his patch (bug #219522)
*rpy-1.0.2 (11 Apr 2008)
diff --git a/dev-python/rpy/files/rpy-1.0.2-rpymodule-R-2.7.patch b/dev-python/rpy/files/rpy-1.0.2-rpymodule-R-2.7.patch
new file mode 100644
index 000000000000..e7ca42e6b1c0
--- /dev/null
+++ b/dev-python/rpy/files/rpy-1.0.2-rpymodule-R-2.7.patch
@@ -0,0 +1,14 @@
+--- rpy-1.0.2.orig/src/rpymodule.c 2008-04-10 18:49:04.000000000 +0200
++++ rpy-1.0.2/src/rpymodule.c 2008-05-02 14:28:42.000000000 +0200
+@@ -1778,7 +1778,11 @@
+ R_dot_Last();
+ R_RunExitFinalizers();
+ CleanEd();
++#if (R_VERSION >= R_Version(2,7,0))
++ Rf_KillAllDevices();
++#else
+ KillAllDevices();
++#endif
+
+ #if (R_VERSION >= R_Version(2,7,0))
+ R_CleanTempDir();
diff --git a/dev-python/rpy/rpy-1.0.2-r1.ebuild b/dev-python/rpy/rpy-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..989d2176028c
--- /dev/null
+++ b/dev-python/rpy/rpy-1.0.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2-r1.ebuild,v 1.1 2008/05/07 08:33:02 bicatali Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-lang/R-2.6.1
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ doc? ( || ( virtual/tetex dev-texlive/texlive-texinfo ) )"
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}"/${PN}-1.0_rc3-version-detect.patch
+ epatch "${FILESDIR}"/${PN}-testfiles.patch
+ epatch "${FILESDIR}"/${P}-rpymodule-R-2.7.patch
+ # this module should exist only if R was built with USE=lapack
+ if [[ -e /usr/$(get_libdir)/R/modules/lapack.so ]]; then
+ sed -i \
+ -e 's:Rlapack:lapack:g' \
+ setup.py || die "sed in setup.py failed"
+ fi
+}
+
+src_test() {
+ cd tests
+ PYTHONPATH=$(ls -d ../build/lib.*) \
+ "${python}" testall.py || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+
+ if use doc; then
+ cd doc
+ emake html pdf || die "emake docs failed"
+ dohtml rpy_html/* || die
+ insinto /usr/share/doc/${PF}
+ doins rpy.pdf || die
+ fi
+}