summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-04-02 22:02:29 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-04-02 22:02:29 +0000
commit5a87b6b181adbc5c30b28a9c4b35233c9e48a78f (patch)
tree2881e8facb4c08e9cdab5420ae1e1dfd3427e23b /dev-python/rtgraph
parentMove mpich from DEPEND to RDEPEND. (Manifest recommit) (diff)
downloadgentoo-2-5a87b6b181adbc5c30b28a9c4b35233c9e48a78f.tar.gz
gentoo-2-5a87b6b181adbc5c30b28a9c4b35233c9e48a78f.tar.bz2
gentoo-2-5a87b6b181adbc5c30b28a9c4b35233c9e48a78f.zip
Initial import, ebuild by Lukasz Strzygowski <lucass@gentoo.pl>.
Diffstat (limited to 'dev-python/rtgraph')
-rw-r--r--dev-python/rtgraph/ChangeLog10
-rw-r--r--dev-python/rtgraph/Manifest2
-rw-r--r--dev-python/rtgraph/files/digest-rtgraph-0.701
-rw-r--r--dev-python/rtgraph/metadata.xml5
-rw-r--r--dev-python/rtgraph/rtgraph-0.70.ebuild25
5 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rtgraph/ChangeLog b/dev-python/rtgraph/ChangeLog
new file mode 100644
index 000000000000..c7609c06f8a3
--- /dev/null
+++ b/dev-python/rtgraph/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/rtgraph
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/ChangeLog,v 1.1 2004/04/02 22:02:29 kloeri Exp $
+
+*rtgraph-0.70 (03 Apr 2004)
+
+ 03 Apr 2004; Bryan Østergaard <kloeri@gentoo.org> metadata.xml,
+ rtgraph-0.70.ebuild:
+ Initial import, ebuild by Lukasz Strzygowski <lucass@gentoo.pl>.
+
diff --git a/dev-python/rtgraph/Manifest b/dev-python/rtgraph/Manifest
new file mode 100644
index 000000000000..7c637c65f5de
--- /dev/null
+++ b/dev-python/rtgraph/Manifest
@@ -0,0 +1,2 @@
+MD5 fdadbee84752c4e5f15363be4c7fa765 rtgraph-0.70.ebuild 747
+MD5 72b9c47b878289b2a6c072cfe5046e66 files/digest-rtgraph-0.70 63
diff --git a/dev-python/rtgraph/files/digest-rtgraph-0.70 b/dev-python/rtgraph/files/digest-rtgraph-0.70
new file mode 100644
index 000000000000..8bd25da0030d
--- /dev/null
+++ b/dev-python/rtgraph/files/digest-rtgraph-0.70
@@ -0,0 +1 @@
+MD5 0f756ffc43cc90bf45ffb80cd2455997 rtgraph-0.70.tar.gz 16141
diff --git a/dev-python/rtgraph/metadata.xml b/dev-python/rtgraph/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/rtgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/rtgraph/rtgraph-0.70.ebuild b/dev-python/rtgraph/rtgraph-0.70.ebuild
new file mode 100644
index 000000000000..84d4bde44d77
--- /dev/null
+++ b/dev-python/rtgraph/rtgraph-0.70.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rtgraph/rtgraph-0.70.ebuild,v 1.1 2004/04/02 22:02:29 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="rtgraph provides several widgets for graphing data in real-time, using PyGTK, and UI components for controlling the graphs."
+HOMEPAGE="http://navi.cx/svn/misc/trunk/rtgraph/web/index.html"
+SRC_URI="http://navi.picogui.org/releases/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+DEPEND="virtual/python
+ >=dev-python/pygtk-2"
+RDEPEND=${DEPEND}
+
+src_install() {
+ distutils_src_install
+ dodoc README BUGS
+ dodir /usr/share/doc/${P}/examples
+ insinto /usr/share/doc/${P}/examples
+ doins cpu_meter.py graph_ui.py isometric_graph.py line_graph.py \
+ polar_graph.py tweak_graph.py
+}