summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-07-25 13:42:30 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-07-25 13:42:30 +0000
commit0c9d6f8482524ecf91d6a05e0f78c16dbbaaedcb (patch)
tree06e5331097909b370d13a6d0c4fedabe0a809a40 /dev-python/ruledispatch
parentInitial commit. (diff)
downloadgentoo-2-0c9d6f8482524ecf91d6a05e0f78c16dbbaaedcb.tar.gz
gentoo-2-0c9d6f8482524ecf91d6a05e0f78c16dbbaaedcb.tar.bz2
gentoo-2-0c9d6f8482524ecf91d6a05e0f78c16dbbaaedcb.zip
Added patch to fix syntax error. Removed older version. Closes bug #264490
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'dev-python/ruledispatch')
-rw-r--r--dev-python/ruledispatch/ChangeLog11
-rw-r--r--dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch49
-rw-r--r--dev-python/ruledispatch/ruledispatch-0.5_pre2306-r1.ebuild (renamed from dev-python/ruledispatch/ruledispatch-0.5_pre2306.ebuild)9
3 files changed, 65 insertions, 4 deletions
diff --git a/dev-python/ruledispatch/ChangeLog b/dev-python/ruledispatch/ChangeLog
index 8974ed875074..ce0ce3980401 100644
--- a/dev-python/ruledispatch/ChangeLog
+++ b/dev-python/ruledispatch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/ruledispatch
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ruledispatch/ChangeLog,v 1.5 2007/07/04 21:05:59 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ruledispatch/ChangeLog,v 1.6 2009/07/25 13:42:30 neurogeek Exp $
+
+*ruledispatch-0.5_pre2306-r1 (25 Jul 2009)
+
+ 25 Jul 2009; Jesus Rivero <neurogeek@gentoo.org>
+ -ruledispatch-0.5_pre2306.ebuild, +ruledispatch-0.5_pre2306-r1.ebuild,
+ +files/ruledispatch_as_syntax_fix.patch:
+ Added patch to fix syntax error. Removed older version. Closes bug #264490
04 Jul 2007; Lukasz Strzygowski <lucass@gentoo.org>
-ruledispatch-0.5_pre2115.ebuild:
diff --git a/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
new file mode 100644
index 000000000000..47960b3c23f5
--- /dev/null
+++ b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
@@ -0,0 +1,49 @@
+Added by: Jesus Rivero (Neurogeek)
+On: 25 Jul 2009
+Per Upstream bug: https://bugs.launchpad.net/ubuntu/+source/ruledispatch/+bug/342916
+
+diff -uNr RuleDispatch.orig/src/dispatch/__init__.py RuleDispatch/src/dispatch/__init__.py
+--- RuleDispatch.orig/src/dispatch/__init__.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/__init__.py 2009-07-25 13:27:19.000000000 +0000
+@@ -95,7 +95,7 @@
+ return decorate_assignment(callback)
+
+
+-def as(*decorators):
++def as_(*decorators):
+ """Use Python 2.4 decorators w/Python 2.2+
+
+ Example:
+Files RuleDispatch.orig/src/dispatch/__init__.pyc and RuleDispatch/src/dispatch/__init__.pyc differ
+Files RuleDispatch.orig/src/dispatch/interfaces.pyc and RuleDispatch/src/dispatch/interfaces.pyc differ
+diff -uNr RuleDispatch.orig/src/dispatch/predicates.py RuleDispatch/src/dispatch/predicates.py
+--- RuleDispatch.orig/src/dispatch/predicates.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/predicates.py 2009-07-25 13:27:58.000000000 +0000
+@@ -236,7 +236,7 @@
+
+ return or_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if item:
+@@ -260,7 +260,7 @@
+
+ return and_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if not item:
+@@ -278,7 +278,7 @@
+ return get(argIds[2])
+ return ifelse, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ if seq[1]: return seq[0]
+ return seq[2]
+
diff --git a/dev-python/ruledispatch/ruledispatch-0.5_pre2306.ebuild b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r1.ebuild
index 2736e54d1bb6..7728d5e76e7c 100644
--- a/dev-python/ruledispatch/ruledispatch-0.5_pre2306.ebuild
+++ b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ruledispatch/ruledispatch-0.5_pre2306.ebuild,v 1.2 2007/05/05 19:51:41 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r1.ebuild,v 1.1 2009/07/25 13:42:30 neurogeek Exp $
+EAPI="2"
NEED_PYTHON=2.4
inherit distutils versionator
@@ -26,6 +27,10 @@ S="${WORKDIR}/${MY_PN}"
PYTHON_MODNAME="dispatch"
+src_prepare(){
+ epatch "${FILESDIR}/${PN}_as_syntax_fix.patch"
+}
+
src_test() {
PYTHONPATH=./src/ "${python}" setup.py test || die "tests failed"
}