summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-03 06:58:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-03 06:58:12 +0000
commitb473850dc2f237ec1ca71332432a42780a669760 (patch)
tree3b3d430d9f10c34801eeba4d8c917b4646a8fdf1 /dev-python/scrapy
parentsci-biology/biopython: Version Bump, thanks Martin Mokrejs <mmokrejs@fold.nat... (diff)
downloadgentoo-2-b473850dc2f237ec1ca71332432a42780a669760.tar.gz
gentoo-2-b473850dc2f237ec1ca71332432a42780a669760.tar.bz2
gentoo-2-b473850dc2f237ec1ca71332432a42780a669760.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/scrapy')
-rw-r--r--dev-python/scrapy/ChangeLog7
-rw-r--r--dev-python/scrapy/scrapy-0.18.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/scrapy/ChangeLog b/dev-python/scrapy/ChangeLog
index 0bc0dedadc8b..3e33c7cc547d 100644
--- a/dev-python/scrapy/ChangeLog
+++ b/dev-python/scrapy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/scrapy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.19 2014/05/26 07:34:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.20 2014/06/03 06:58:12 idella4 Exp $
+
+*scrapy-0.18.4 (03 Jun 2014)
+
+ 03 Jun 2014; Ian Delaney <idella4@gentoo.org> +scrapy-0.18.4.ebuild:
+ bump
*scrapy-0.18.3 (26 May 2014)
diff --git a/dev-python/scrapy/scrapy-0.18.4.ebuild b/dev-python/scrapy/scrapy-0.18.4.ebuild
new file mode 100644
index 000000000000..deb64cb01999
--- /dev/null
+++ b/dev-python/scrapy/scrapy-0.18.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.4.ebuild,v 1.1 2014/06/03 06:58:12 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="A high-level Python Screen Scraping framework"
+HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boto doc ibl test ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ boto? ( dev-python/boto[${PYTHON_USEDEP}] )
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-conch[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ >=dev-python/w3lib-1.2[${PYTHON_USEDEP}]
+ dev-python/queuelib[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ net-ftp/vsftpd
+ dev-python/pillow[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ssl )"
+
+python_prepare_all() {
+ # Skip failing tests; https://github.com/scrapy/scrapy/issues/725
+ sed -e s':test_validation:_&:' \
+ -i scrapy/tests/test_djangoitem/__init__.py || die
+ sed -e s':test_process_parallel_failure:_&:' \
+ -i scrapy/tests/test_utils_defer.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${PWD}" bin/runtests.sh || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}