summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 03:23:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 03:23:50 +0000
commitb5185cec7a3b88d70bd7b36caf30f3cd7035b1c2 (patch)
treea714e9d592469f0d24d9a0135960a1c8fe158908 /dev-python/setuptools
parentFixed fonts handling. Fixed texmf override issue. Removed old versions. (diff)
downloadgentoo-2-b5185cec7a3b88d70bd7b36caf30f3cd7035b1c2.tar.gz
gentoo-2-b5185cec7a3b88d70bd7b36caf30f3cd7035b1c2.tar.bz2
gentoo-2-b5185cec7a3b88d70bd7b36caf30f3cd7035b1c2.zip
Fix tests with Python 3.1.
(Portage version: 14821-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog6
-rw-r--r--dev-python/setuptools/files/distribute-0.6.8-fix_tests.patch49
-rw-r--r--dev-python/setuptools/setuptools-0.6.8.ebuild5
3 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 4cdb1a8a4a75..dfbbac2f9cbb 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.86 2009/11/12 15:54:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.87 2009/11/15 03:23:50 arfrever Exp $
+
+ 15 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ setuptools-0.6.8.ebuild, +files/distribute-0.6.8-fix_tests.patch:
+ Fix tests with Python 3.1.
12 Nov 2009; Jeroen Roovers <jer@gentoo.org> setuptools-0.6.3-r3.ebuild,
setuptools-0.6.4.ebuild, setuptools-0.6.6.ebuild:
diff --git a/dev-python/setuptools/files/distribute-0.6.8-fix_tests.patch b/dev-python/setuptools/files/distribute-0.6.8-fix_tests.patch
new file mode 100644
index 000000000000..41b1779f3b48
--- /dev/null
+++ b/dev-python/setuptools/files/distribute-0.6.8-fix_tests.patch
@@ -0,0 +1,49 @@
+https://bitbucket.org/tarek/distribute/issue/80/
+https://bitbucket.org/tarek/distribute/changeset/e2de9f1e9064/
+
+--- setuptools/command/__init__.py
++++ setuptools/command/__init__.py
+@@ -5,13 +5,16 @@
+ 'register', 'bdist_wininst', 'upload_docs',
+ ]
+
++from setuptools.command.install_scripts import install_scripts
+ import sys
++
+ if sys.version>='2.5':
+ # In Python 2.5 and above, distutils includes its own upload command
+ __all__.remove('upload')
+
+ from distutils.command.bdist import bdist
+
++
+ if 'egg' not in bdist.format_commands:
+ bdist.format_command['egg'] = ('bdist_egg', "Python .egg file")
+ bdist.format_commands.append('egg')
+--- setuptools/command/install_scripts.py
++++ setuptools/command/install_scripts.py
+@@ -1,6 +1,5 @@
+ from distutils.command.install_scripts import install_scripts \
+ as _install_scripts
+-from easy_install import get_script_args, sys_executable, chmod
+ from pkg_resources import Distribution, PathMetadata, ensure_directory
+ import os
+ from distutils import log
+@@ -13,6 +12,9 @@
+ self.no_ep = False
+
+ def run(self):
++ from setuptools.command.easy_install import (get_script_args,
++ sys_executable)
++
+ self.run_command("egg_info")
+ if self.distribution.scripts:
+ _install_scripts.run(self) # run first to set up self.outfiles
+@@ -37,6 +39,7 @@
+
+ def write_script(self, script_name, contents, mode="t", *ignored):
+ """Write an executable file to the scripts directory"""
++ from setuptools.command.easy_install import chmod
+ log.info("Installing %s script to %s", script_name, self.install_dir)
+ target = os.path.join(self.install_dir, script_name)
+ self.outfiles.append(target)
diff --git a/dev-python/setuptools/setuptools-0.6.8.ebuild b/dev-python/setuptools/setuptools-0.6.8.ebuild
index bdd544d7f4f9..3e6486aabec6 100644
--- a/dev-python/setuptools/setuptools-0.6.8.ebuild
+++ b/dev-python/setuptools/setuptools-0.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.8.ebuild,v 1.5 2009/11/12 21:23:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.8.ebuild,v 1.6 2009/11/15 03:23:50 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -38,6 +38,9 @@ src_prepare() {
# https://bitbucket.org/tarek/distribute/issue/87/
sed -e 's:if copied and outf.endswith(".py"):& and outf != "build/src/distribute_setup.py":' -i setup.py || die "sed setup.py failed"
+
+ # https://bitbucket.org/tarek/distribute/issue/80/
+ epatch "${FILESDIR}/${MY_P}-fix_tests.patch"
}
src_test() {