summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-23 19:51:01 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-23 19:51:01 +0000
commite5f9a9d0e2c56e6db262159bac392a1bca0e8ff7 (patch)
tree08e81b35451b5d1fc72a67dd5561a56b7f2fa76c /dev-python/simplecv
parentFix building with SYMLINK_LIB=no #505760 by Georgi Georgiev. Sync the non-999... (diff)
downloadgentoo-2-e5f9a9d0e2c56e6db262159bac392a1bca0e8ff7.tar.gz
gentoo-2-e5f9a9d0e2c56e6db262159bac392a1bca0e8ff7.tar.bz2
gentoo-2-e5f9a9d0e2c56e6db262159bac392a1bca0e8ff7.zip
Fix Python dependencies. Switch to single impl because of deps.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/simplecv')
-rw-r--r--dev-python/simplecv/ChangeLog6
-rw-r--r--dev-python/simplecv/simplecv-1.3.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/simplecv/ChangeLog b/dev-python/simplecv/ChangeLog
index 563af00b17c6..090120616fce 100644
--- a/dev-python/simplecv/ChangeLog
+++ b/dev-python/simplecv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/simplecv
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplecv/ChangeLog,v 1.3 2014/01/24 21:32:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplecv/ChangeLog,v 1.4 2014/04/23 19:51:01 mgorny Exp $
+
+ 23 Apr 2014; Michał Górny <mgorny@gentoo.org> simplecv-1.3.ebuild:
+ Fix Python dependencies. Switch to single impl because of deps.
24 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org> simplecv-1.3.ebuild:
Fix OpenCV dependencies (new useflag, migration to python-single-r1)
@@ -15,4 +18,3 @@
+files/remove-failing-test.patch, +files/remove-failing-tests.patch,
+metadata.xml:
Initial import
-
diff --git a/dev-python/simplecv/simplecv-1.3.ebuild b/dev-python/simplecv/simplecv-1.3.ebuild
index 7602db75228c..ea46efc86112 100644
--- a/dev-python/simplecv/simplecv-1.3.ebuild
+++ b/dev-python/simplecv/simplecv-1.3.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplecv/simplecv-1.3.ebuild,v 1.3 2014/01/24 21:32:21 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplecv/simplecv-1.3.ebuild,v 1.4 2014/04/23 19:51:01 mgorny Exp $
EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 vcs-snapshot
@@ -22,7 +24,7 @@ DEPEND="
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="
- || ( <media-libs/opencv-2.4.8 >=media-libs/opencv-2.4.8[python,${PYTHON_USEDEP}] )
+ >=media-libs/opencv-2.4.8[python,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
virtual/python-imaging[${PYTHON_USEDEP}]