summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-05-06 05:02:37 +0000
committerTim Harder <radhermit@gentoo.org>2014-05-06 05:02:37 +0000
commitd6264af015ee24a168c6f16211b5202bca7e2a39 (patch)
tree40a90ed044a53429d7decb78593ba3be5d90a49e /dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d6264af015ee24a168c6f16211b5202bca7e2a39.tar.gz
gentoo-2-d6264af015ee24a168c6f16211b5202bca7e2a39.tar.bz2
gentoo-2-d6264af015ee24a168c6f16211b5202bca7e2a39.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild')
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild
new file mode 100644
index 000000000000..4e0bd32561fb
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sleekxmpp/sleekxmpp-1.2.5.ebuild,v 1.1 2014/05/06 05:02:37 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils distutils-r1
+
+MY_PN=SleekXMPP
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python library for XMPP"
+HOMEPAGE="http://sleekxmpp.com/ https://github.com/fritzy/SleekXMPP/"
+SRC_URI="https://github.com/fritzy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}