summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-01 16:43:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-01 16:43:20 +0000
commit0c71eba5958aef8811b1482b564e3b485cd24a2e (patch)
tree1aeb703da713e1d56545087ce75746a99ea2b143 /dev-python/spyder
parentDelete older ebuild. (diff)
downloadgentoo-2-0c71eba5958aef8811b1482b564e3b485cd24a2e.tar.gz
gentoo-2-0c71eba5958aef8811b1482b564e3b485cd24a2e.tar.bz2
gentoo-2-0c71eba5958aef8811b1482b564e3b485cd24a2e.zip
Version bump.
(Portage version: 2.2.0_alpha25_p13/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog8
-rw-r--r--dev-python/spyder/spyder-2.0.8.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index c7f9530e5d59..f3b77838b20b 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.15 2011/01/10 18:00:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.16 2011/03/01 16:43:20 arfrever Exp $
+
+*spyder-2.0.8 (01 Mar 2011)
+
+ 01 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -spyder-2.0.6.ebuild, +spyder-2.0.8.ebuild:
+ Version bump.
*spyder-2.0.6 (10 Jan 2011)
diff --git a/dev-python/spyder/spyder-2.0.8.ebuild b/dev-python/spyder/spyder-2.0.8.ebuild
new file mode 100644
index 000000000000..76f6e005e6b7
--- /dev/null
+++ b/dev-python/spyder/spyder-2.0.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.8.ebuild,v 1.1 2011/03/01 16:43:20 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ ipython? ( dev-python/ipython )
+ matplotlib? ( dev-python/matplotlib )
+ numpy? ( dev-python/numpy )
+ pyflakes? ( >=dev-python/pyflakes-0.3 )
+ pylint? ( dev-python/pylint )
+ rope? ( >=dev-python/rope-0.9.0 )
+ scipy? ( sci-libs/scipy )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.0.4-disable_sphinx_dependency.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd doc_output > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}