summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-27 02:42:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-27 02:42:11 +0000
commit3560faac005c0b877a906829d95f8086815341cc (patch)
treea15bfe80b6a540f3933d3a1cc4a94e5c976e2aa6 /dev-python/sqlalchemy-migrate
parentadd ebuild for dockerpty—dependence of fig (diff)
downloadgentoo-2-3560faac005c0b877a906829d95f8086815341cc.tar.gz
gentoo-2-3560faac005c0b877a906829d95f8086815341cc.tar.bz2
gentoo-2-3560faac005c0b877a906829d95f8086815341cc.zip
Restore version needed by buildbot
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-python/sqlalchemy-migrate')
-rw-r--r--dev-python/sqlalchemy-migrate/ChangeLog8
-rw-r--r--dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2-r1.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/sqlalchemy-migrate/ChangeLog b/dev-python/sqlalchemy-migrate/ChangeLog
index f7aef4371848..9d52c9602e36 100644
--- a/dev-python/sqlalchemy-migrate/ChangeLog
+++ b/dev-python/sqlalchemy-migrate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sqlalchemy-migrate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy-migrate/ChangeLog,v 1.37 2014/10/22 14:20:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy-migrate/ChangeLog,v 1.38 2014/10/27 02:42:11 patrick Exp $
+
+*sqlalchemy-migrate-0.7.2-r1 (27 Oct 2014)
+
+ 27 Oct 2014; Patrick Lauer <patrick@gentoo.org>
+ +sqlalchemy-migrate-0.7.2-r1.ebuild:
+ Restore version needed by buildbot
22 Oct 2014; Ian Delaney <idella4@gentoo.org> sqlalchemy-migrate-0.9.2.ebuild:
drop py3 support, found to be not py3 ready, cross tested by Arfrever
diff --git a/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2-r1.ebuild b/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..b63e9e1b472d
--- /dev/null
+++ b/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2-r1.ebuild,v 1.5 2014/10/27 02:42:11 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="SQLAlchemy Schema Migration Tools"
+HOMEPAGE="http://code.google.com/p/sqlalchemy-migrate/ http://pypi.python.org/pypi/sqlalchemy-migrate"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.6[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
+ dev-python/tempita[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# for tests: unittest2 and scripttest