summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-07 13:31:19 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-07 13:31:19 +0000
commit2f334946eebcc0e84ea1432d6ffe0156ee962f98 (patch)
treeaf964baf4efe9bd4279cb21b80542f59de1ebb28 /dev-python/statsmodels
parentDrop dev-lang/perl dependency (diff)
downloadgentoo-2-2f334946eebcc0e84ea1432d6ffe0156ee962f98.tar.gz
gentoo-2-2f334946eebcc0e84ea1432d6ffe0156ee962f98.tar.bz2
gentoo-2-2f334946eebcc0e84ea1432d6ffe0156ee962f98.zip
dev-python/statsmodels: Version BUmp; add py3.4 compatibility, #530606; working testsuite, #530270
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/ChangeLog10
-rw-r--r--dev-python/statsmodels/metadata.xml12
-rw-r--r--dev-python/statsmodels/statsmodels-0.6.1.ebuild71
3 files changed, 85 insertions, 8 deletions
diff --git a/dev-python/statsmodels/ChangeLog b/dev-python/statsmodels/ChangeLog
index 49a0fa9cece5..36f1bdb44e3e 100644
--- a/dev-python/statsmodels/ChangeLog
+++ b/dev-python/statsmodels/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/statsmodels
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/statsmodels/ChangeLog,v 1.4 2013/10/27 08:26:43 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/statsmodels/ChangeLog,v 1.5 2014/12/07 13:31:19 jlec Exp $
+
+*statsmodels-0.6.1 (07 Dec 2014)
+
+ 07 Dec 2014; Justin Lecher <jlec@gentoo.org> +statsmodels-0.6.1.ebuild,
+ metadata.xml:
+ Version BUmp; add py3.4 compatibility, #530606; working testsuite, #530270
27 Oct 2013; Michał Górny <mgorny@gentoo.org> statsmodels-0.5.0.ebuild:
Remove redundant python_export_best (done by the eclass).
diff --git a/dev-python/statsmodels/metadata.xml b/dev-python/statsmodels/metadata.xml
index acba75ad5377..81cea1512e61 100644
--- a/dev-python/statsmodels/metadata.xml
+++ b/dev-python/statsmodels/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>python</herd>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
statsmodels is a Python module that allows users to explore data,
estimate statistical models, and perform statistical tests. An
extensive list of descriptive statistics, statistical tests,
@@ -12,7 +12,7 @@
fields may find that statsmodels fully meets their needs for
statistical computing and data analysis in Python.
</longdescription>
-<upstream>
- <remote-id type="pypi">statsmodels</remote-id>
-</upstream>
+ <upstream>
+ <remote-id type="pypi">statsmodels</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/statsmodels/statsmodels-0.6.1.ebuild b/dev-python/statsmodels/statsmodels-0.6.1.ebuild
new file mode 100644
index 000000000000..e744e8fb70e0
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-0.6.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/statsmodels/statsmodels-0.6.1.ebuild,v 1.1 2014/12/07 13:31:19 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="http://statsmodels.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND="
+ >=dev-python/numpy-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/patsy-0.3.0[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.9.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ examples? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+DEPEND="${CDEPEND}
+ >=dev-python/cython-0.20.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/matplotlib-1.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ export MPLCONFIGDIR="${T}" HOME="${T}"
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts ${EPYTHON} setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ VIRTUALX_COMMAND="nosetests"
+ virtualmake --verbosity=3
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete
+ use doc && HTML_DOCS=( build/sphinx/html/* )
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "plotting functionality" >=dev-python/matplotlib-1.1[${PYTHON_USEDEP}]
+}