summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-21 22:08:52 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-21 22:08:52 +0000
commit6ad122d9a6f70c8baf7dbb8dbf387571427cb199 (patch)
treedfe9437267807015df15f6da4c6180f7776f223e /dev-python/subvertpy
parentarm stable, bug #394393 (diff)
downloadgentoo-2-6ad122d9a6f70c8baf7dbb8dbf387571427cb199.tar.gz
gentoo-2-6ad122d9a6f70c8baf7dbb8dbf387571427cb199.tar.bz2
gentoo-2-6ad122d9a6f70c8baf7dbb8dbf387571427cb199.zip
Version bump.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/ChangeLog7
-rw-r--r--dev-python/subvertpy/subvertpy-0.8.9.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index b3aa337361ee..53ad5fbe38e5 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.33 2011/10/11 14:56:10 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.34 2011/12/21 22:08:52 floppym Exp $
+
+*subvertpy-0.8.9 (21 Dec 2011)
+
+ 21 Dec 2011; Mike Gilbert <floppym@gentoo.org> +subvertpy-0.8.9.ebuild:
+ Version bump.
*subvertpy-0.8.8 (11 Oct 2011)
diff --git a/dev-python/subvertpy/subvertpy-0.8.9.ebuild b/dev-python/subvertpy/subvertpy-0.8.9.ebuild
new file mode 100644
index 000000000000..687094091523
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.8.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.8.9.ebuild,v 1.1 2011/12/21 22:08:52 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-vcs/subversion-1.4"
+RDEPEND="${DEPEND}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}