summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2013-06-15 16:02:39 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2013-06-15 16:02:39 +0000
commit397cbadd0a9a262cf5b9e4f801bed8633c10286e (patch)
tree62509a13ce7f97e765b3e90d54ac4325b96cee17 /dev-python/tdaemon/tdaemon-0.1.6.ebuild
parentOld. (diff)
downloadgentoo-2-397cbadd0a9a262cf5b9e4f801bed8633c10286e.tar.gz
gentoo-2-397cbadd0a9a262cf5b9e4f801bed8633c10286e.tar.bz2
gentoo-2-397cbadd0a9a262cf5b9e4f801bed8633c10286e.zip
Version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x57DC0078)
Diffstat (limited to 'dev-python/tdaemon/tdaemon-0.1.6.ebuild')
-rw-r--r--dev-python/tdaemon/tdaemon-0.1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tdaemon/tdaemon-0.1.6.ebuild b/dev-python/tdaemon/tdaemon-0.1.6.ebuild
new file mode 100644
index 000000000000..3184b6da2d0d
--- /dev/null
+++ b/dev-python/tdaemon/tdaemon-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tdaemon/tdaemon-0.1.6.ebuild,v 1.1 2013/06/15 16:02:39 tampakrap Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Daemon"
+HOMEPAGE="http://github.com/brunobord/tdaemon"
+SRC_URI="https://github.com/tampakrap/tdaemon/archive/v${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="coverage"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ if "${PYTHON}" -m test; then
+ einfo "Test passed under ${EPYTHON}"
+ else
+ die "Test failed under ${EPYTHON}"
+ fi
+}