summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-30 08:29:58 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-30 08:29:58 +0000
commitee43f9bd4c30b4e3669ea9a423653a84971b3e58 (patch)
tree73adf43be88cb2062d4d52a30aad6cf25e2cf59e /dev-python/tpg
parentFix rfcomm init.d script (#505786 by Christophe PEREZ and Bombino) (diff)
downloadgentoo-2-ee43f9bd4c30b4e3669ea9a423653a84971b3e58.tar.gz
gentoo-2-ee43f9bd4c30b4e3669ea9a423653a84971b3e58.tar.bz2
gentoo-2-ee43f9bd4c30b4e3669ea9a423653a84971b3e58.zip
revbump; conversion -> distutils-r1 eclass, Add py2 support, fixes Bug #497508 by jarausch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tpg')
-rw-r--r--dev-python/tpg/ChangeLog9
-rw-r--r--dev-python/tpg/tpg-3.1.2.ebuild46
-rw-r--r--dev-python/tpg/tpg-3.1.4.ebuild46
-rw-r--r--dev-python/tpg/tpg-3.2.1.ebuild47
-rw-r--r--dev-python/tpg/tpg-3.2.2-r1.ebuild32
5 files changed, 40 insertions, 140 deletions
diff --git a/dev-python/tpg/ChangeLog b/dev-python/tpg/ChangeLog
index b44d892e28d9..30f229c6184f 100644
--- a/dev-python/tpg/ChangeLog
+++ b/dev-python/tpg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/tpg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/ChangeLog,v 1.18 2014/01/08 05:33:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/ChangeLog,v 1.19 2014/03/30 08:29:58 idella4 Exp $
+
+*tpg-3.2.2-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Ian Delaney <idella4@gentoo.org> +tpg-3.2.2-r1.ebuild,
+ -tpg-3.1.2.ebuild, -tpg-3.1.4.ebuild, -tpg-3.2.1.ebuild:
+ revbump; conversion -> distutils-r1 eclass, Add py2 support, fixes Bug #497508
+ by jarausch
*tpg-3.2.2 (08 Jan 2014)
diff --git a/dev-python/tpg/tpg-3.1.2.ebuild b/dev-python/tpg/tpg-3.1.2.ebuild
deleted file mode 100644
index e18ceb79af2d..000000000000
--- a/dev-python/tpg/tpg-3.1.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.1.2.ebuild,v 1.2 2010/12/26 17:31:38 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_P="TPG-${PV}"
-
-DESCRIPTION="Toy Parser Generator for Python"
-HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
-SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="THANKS"
-PYTHON_MODNAME="tpg.py"
-
-src_test() {
- testing() {
- "$(PYTHON)" tpg_tests.py -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/tpg.pdf || die "dodoc failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
- fi
-}
diff --git a/dev-python/tpg/tpg-3.1.4.ebuild b/dev-python/tpg/tpg-3.1.4.ebuild
deleted file mode 100644
index 907428e9935f..000000000000
--- a/dev-python/tpg/tpg-3.1.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.1.4.ebuild,v 1.1 2012/03/09 09:59:31 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_P="TPG-${PV}"
-
-DESCRIPTION="Toy Parser Generator for Python"
-HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
-SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="THANKS"
-PYTHON_MODNAME="tpg.py"
-
-src_test() {
- testing() {
- "$(PYTHON)" tpg_tests.py -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/tpg.pdf || die "dodoc failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
- fi
-}
diff --git a/dev-python/tpg/tpg-3.2.1.ebuild b/dev-python/tpg/tpg-3.2.1.ebuild
deleted file mode 100644
index 8d4beba06a38..000000000000
--- a/dev-python/tpg/tpg-3.2.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.2.1.ebuild,v 1.1 2012/06/06 08:06:46 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-PYTHON_TESTS_RESTRICTED_ABIS="2.5 2.6"
-
-inherit distutils
-
-MY_P="TPG-${PV}"
-
-DESCRIPTION="Toy Parser Generator for Python"
-HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
-SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="THANKS"
-PYTHON_MODNAME="tpg.py"
-
-src_test() {
- testing() {
- "$(PYTHON)" tpg_tests.py -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dodoc doc/tpg.pdf || die "dodoc failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
- fi
-}
diff --git a/dev-python/tpg/tpg-3.2.2-r1.ebuild b/dev-python/tpg/tpg-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..a90cbefb78de
--- /dev/null
+++ b/dev-python/tpg/tpg-3.2.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tpg/tpg-3.2.2-r1.ebuild,v 1.1 2014/03/30 08:29:58 idella4 Exp $
+
+EAPI=5
+# py2.6 doesn't pass tests
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_P="TPG-${PV}"
+
+DESCRIPTION="Toy Parser Generator for Python"
+HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
+SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc examples"
+DOCS=( ChangeLog README THANKS doc/tpg.pdf )
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" tpg_tests.py -v || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}