summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:06:17 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:06:17 +0000
commit734d375d10170a8b8e453593165bf0061de59b4e (patch)
tree6006c51d51f23675b304045c1b8d22162461d864 /dev-python/twisted-conch
parentVersion bump, bug #88342. (diff)
downloadgentoo-2-734d375d10170a8b8e453593165bf0061de59b4e.tar.gz
gentoo-2-734d375d10170a8b8e453593165bf0061de59b4e.tar.bz2
gentoo-2-734d375d10170a8b8e453593165bf0061de59b4e.zip
initial import
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python/twisted-conch')
-rw-r--r--dev-python/twisted-conch/ChangeLog8
-rw-r--r--dev-python/twisted-conch/Manifest4
-rw-r--r--dev-python/twisted-conch/files/digest-twisted-conch-0.5.01
-rw-r--r--dev-python/twisted-conch/metadata.xml6
-rw-r--r--dev-python/twisted-conch/twisted-conch-0.5.0.ebuild31
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
new file mode 100644
index 000000000000..ca2ebf2e8f3f
--- /dev/null
+++ b/dev-python/twisted-conch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/twisted-conch
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.1 2005/04/08 14:06:17 lordvan Exp $
+
+ 08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-conch-0.5.0:
+ initial import
+ twisted-conch was part of the main twisted release
+
diff --git a/dev-python/twisted-conch/Manifest b/dev-python/twisted-conch/Manifest
new file mode 100644
index 000000000000..0e32b66d5a2c
--- /dev/null
+++ b/dev-python/twisted-conch/Manifest
@@ -0,0 +1,4 @@
+MD5 4ba902c44ec244466140da5a56aaf38b twisted-conch-0.5.0.ebuild 824
+MD5 e275c0b987aa40432389e6bc1c87f4a3 ChangeLog 344
+MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
+MD5 4e7bf4c8e53132875fc7bc7182c590e9 files/digest-twisted-conch-0.5.0 71
diff --git a/dev-python/twisted-conch/files/digest-twisted-conch-0.5.0 b/dev-python/twisted-conch/files/digest-twisted-conch-0.5.0
new file mode 100644
index 000000000000..93e0d0547e4d
--- /dev/null
+++ b/dev-python/twisted-conch/files/digest-twisted-conch-0.5.0
@@ -0,0 +1 @@
+MD5 42961532a130bb119ae3be6b14dde28b TwistedConch-0.5.0.tar.bz2 118875
diff --git a/dev-python/twisted-conch/metadata.xml b/dev-python/twisted-conch/metadata.xml
new file mode 100644
index 000000000000..37d1f8e02e49
--- /dev/null
+++ b/dev-python/twisted-conch/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer><email>lordvan@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/twisted-conch/twisted-conch-0.5.0.ebuild b/dev-python/twisted-conch/twisted-conch-0.5.0.ebuild
new file mode 100644
index 000000000000..fe1e9f2ae2fe
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-0.5.0.ebuild,v 1.1 2005/04/08 14:06:17 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedConch"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="An SSH and SFTP protocol implementation together with clients and servers."
+HOMEPAGE="http://twistedmatrix.com/projects/conch/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Conch/0.5/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}