summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-12 03:51:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-12 03:51:12 +0000
commit77c810ac9a231679913fd8570689db5468867953 (patch)
tree9a7efacee947a4f2192ff09db875bef4d514fec7 /dev-python/twisted-web
parentDelete redundant comment (diff)
downloadgentoo-2-77c810ac9a231679913fd8570689db5468867953.tar.gz
gentoo-2-77c810ac9a231679913fd8570689db5468867953.tar.bz2
gentoo-2-77c810ac9a231679913fd8570689db5468867953.zip
bump, drop py2.6
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog7
-rw-r--r--dev-python/twisted-web/twisted-web-14.0.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index df6a935799ee..c76c6fe98da8 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.111 2014/09/15 08:19:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.112 2014/11/12 03:51:12 idella4 Exp $
+
+*twisted-web-14.0.1 (12 Nov 2014)
+
+ 12 Nov 2014; Ian Delaney <idella4@gentoo.org> +twisted-web-14.0.1.ebuild:
+ bump, drop py2.6
15 Sep 2014; Agostino Sarubbo <ago@gentoo.org> twisted-web-13.0.0-r1.ebuild:
Stable for sparc, wrt bug #512012
diff --git a/dev-python/twisted-web/twisted-web-14.0.1.ebuild b/dev-python/twisted-web/twisted-web-14.0.1.ebuild
new file mode 100644
index 000000000000..0e8f6e988a3d
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-14.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-14.0.1.ebuild,v 1.1 2014/11/12 03:51:12 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite