summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-21 05:04:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-21 05:04:39 +0000
commit3022aad6fd8a1c1ede119211e152cbb174d3ffda (patch)
treeedc0ca43a256745864aa8911b57101b7ec3861fb /dev-python/wtf-peewee
parentBump (diff)
downloadgentoo-2-3022aad6fd8a1c1ede119211e152cbb174d3ffda.tar.gz
gentoo-2-3022aad6fd8a1c1ede119211e152cbb174d3ffda.tar.bz2
gentoo-2-3022aad6fd8a1c1ede119211e152cbb174d3ffda.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wtf-peewee')
-rw-r--r--dev-python/wtf-peewee/ChangeLog7
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.1.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/wtf-peewee/ChangeLog b/dev-python/wtf-peewee/ChangeLog
index b566f14f8e52..ad9e77947e70 100644
--- a/dev-python/wtf-peewee/ChangeLog
+++ b/dev-python/wtf-peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtf-peewee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.1 2013/08/17 04:36:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.2 2013/10/21 05:04:39 patrick Exp $
+
+*wtf-peewee-0.1.4 (21 Oct 2013)
+
+ 21 Oct 2013; Patrick Lauer <patrick@gentoo.org> +wtf-peewee-0.1.4.ebuild:
+ Bump
*wtf-peewee-0.1.3 (17 Aug 2013)
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.1.4.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.1.4.ebuild
new file mode 100644
index 000000000000..e0b105aec96b
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.1.4.ebuild,v 1.1 2013/10/21 05:04:39 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ "
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}