summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-19 10:14:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-19 10:14:00 +0000
commit5a568b28ee458234a214366588c25f8aa1c1d8bc (patch)
treef22a8e53be3adf94dfcbd27ff1a54ecc02693f59 /dev-python/xlwt/xlwt-0.7.4.ebuild
parentBump (diff)
downloadgentoo-2-5a568b28ee458234a214366588c25f8aa1c1d8bc.tar.gz
gentoo-2-5a568b28ee458234a214366588c25f8aa1c1d8bc.tar.bz2
gentoo-2-5a568b28ee458234a214366588c25f8aa1c1d8bc.zip
Bump
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/xlwt/xlwt-0.7.4.ebuild')
-rw-r--r--dev-python/xlwt/xlwt-0.7.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xlwt/xlwt-0.7.4.ebuild b/dev-python/xlwt/xlwt-0.7.4.ebuild
new file mode 100644
index 000000000000..c007883e1644
--- /dev/null
+++ b/dev-python/xlwt/xlwt-0.7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlwt/xlwt-0.7.4.ebuild,v 1.1 2012/04/19 10:14:00 patrick Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
+HOMEPAGE="http://pypi.python.org/pypi/xlwt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't install documentation and examples in site-packages directories.
+ sed -e "/package_data/,+6d" -i setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r HISTORY.html xlwt/doc/xlwt.html tests
+ if use examples; then
+ doins -r xlwt/examples || die "doins failed"
+ fi
+}