summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:22:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:22:42 +0000
commitecb09a0324f070f535261482eeef0f92896314f5 (patch)
tree6b528cc6d373f6a3c1c56e209dcd6fb8d1ffe0fd /dev-python/xlwt
parentFix LICENSE (#301969). Maintenance (diff)
downloadgentoo-2-ecb09a0324f070f535261482eeef0f92896314f5.tar.gz
gentoo-2-ecb09a0324f070f535261482eeef0f92896314f5.tar.bz2
gentoo-2-ecb09a0324f070f535261482eeef0f92896314f5.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 15324-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/xlwt')
-rw-r--r--dev-python/xlwt/ChangeLog8
-rw-r--r--dev-python/xlwt/xlwt-0.7.2.ebuild31
2 files changed, 27 insertions, 12 deletions
diff --git a/dev-python/xlwt/ChangeLog b/dev-python/xlwt/ChangeLog
index 0bcb9facc2d1..e20bf77b263a 100644
--- a/dev-python/xlwt/ChangeLog
+++ b/dev-python/xlwt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/xlwt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlwt/ChangeLog,v 1.8 2009/11/08 19:54:56 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlwt/ChangeLog,v 1.9 2010/02/06 14:22:42 arfrever Exp $
+
+ 06 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ xlwt-0.7.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
08 Nov 2009; nixnut <nixnut@gentoo.org> xlwt-0.7.2.ebuild:
ppc stable #290607
diff --git a/dev-python/xlwt/xlwt-0.7.2.ebuild b/dev-python/xlwt/xlwt-0.7.2.ebuild
index 5e69c5bda901..2bad30675721 100644
--- a/dev-python/xlwt/xlwt-0.7.2.ebuild
+++ b/dev-python/xlwt/xlwt-0.7.2.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlwt/xlwt-0.7.2.ebuild,v 1.3 2009/11/08 19:54:56 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlwt/xlwt-0.7.2.ebuild,v 1.4 2010/02/06 14:22:42 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-EAPI=2
inherit distutils
DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
@@ -14,23 +17,31 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="examples"
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
src_prepare() {
- # prevint installing from doc and examples in python libdir
- sed -i \
- -e '/package_data/,+6d' \
- setup.py || die
+ distutils_src_prepare
+
+ # Don't install documentation and examples in site-packages directories.
+ sed -e "/package_data/,+6d" -i setup.py || die "sed failed"
}
src_test() {
- cd "${S}"/tests
- PYTHONPATH=../build/lib "${python}" RKbug.py 1 || die "test failed"
+ cd tests
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" RKbug.py 1
+ }
+ python_execute_function testing
}
src_install() {
distutils_src_install
+
insinto /usr/share/doc/${PF}
doins -r HISTORY.html xlwt/doc/xlwt.html tests
if use examples; then
- doins -r xlwt/examples || die
+ doins -r xlwt/examples || die "doins failed"
fi
}