summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-19 15:47:36 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-19 15:47:36 +0000
commit0df0c62deab8749d917f920d10901625421c96d8 (patch)
tree9afec77306a63fd3ff5abbb5e380acf1fba0ab2b /dev-python
parentFix tcl/tk slotting (diff)
downloadgentoo-2-0df0c62deab8749d917f920d10901625421c96d8.tar.gz
gentoo-2-0df0c62deab8749d917f920d10901625421c96d8.tar.bz2
gentoo-2-0df0c62deab8749d917f920d10901625421c96d8.zip
revbump; add py3 support, update HOMEPAGE, switch SRC_URI to repo to acquire a complete tarball, update deps for tests and msg to users re optional cryptographic support, rm obsolete
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beaker/ChangeLog10
-rw-r--r--dev-python/beaker/beaker-1.7.0-r1.ebuild50
-rw-r--r--dev-python/beaker/beaker-1.7.0.ebuild39
3 files changed, 59 insertions, 40 deletions
diff --git a/dev-python/beaker/ChangeLog b/dev-python/beaker/ChangeLog
index 3ae97baa3c08..0c5169aea761 100644
--- a/dev-python/beaker/ChangeLog
+++ b/dev-python/beaker/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/beaker
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beaker/ChangeLog,v 1.62 2015/03/19 06:07:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beaker/ChangeLog,v 1.63 2015/03/19 15:47:36 idella4 Exp $
+
+*beaker-1.7.0-r1 (19 Mar 2015)
+
+ 19 Mar 2015; Ian Delaney <idella4@gentoo.org> +beaker-1.7.0-r1.ebuild,
+ -beaker-1.7.0.ebuild:
+ revbump; add py3 support, update HOMEPAGE, switch SRC_URI to repo to acquire a
+ complete tarball, update deps for tests and msg to users re optional
+ cryptographic support, rm obsolete
*beaker-1.7.0 (19 Mar 2015)
diff --git a/dev-python/beaker/beaker-1.7.0-r1.ebuild b/dev-python/beaker/beaker-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..a5e068bdbda6
--- /dev/null
+++ b/dev-python/beaker/beaker-1.7.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beaker/beaker-1.7.0-r1.ebuild,v 1.1 2015/03/19 15:47:36 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Session and Caching library with WSGI Middleware"
+HOMEPAGE="https://github.com/bbangert/beaker http://pypi.python.org/pypi/Beaker"
+SRC_URI="https://github.com/bbangert/${PN}/archive/v1.7.0dev.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+# webtest-based tests are skipped when webtest is not installed
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${P}dev"
+
+python_prepare_all() {
+ # Workaround for http://bugs.python.org/issue11276.
+ sed -e "s/import anydbm/& as anydbm/;/import anydbm/a dbm = anydbm" \
+ -i beaker/container.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+ pushd "${BUILD_DIR}"/tests > /dev/null
+ nosetests || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null
+}
+
+pkg_postinst() {
+ elog "beaker also has optional support for packages"
+ elog "pycrypto and pycryptopp"
+}
diff --git a/dev-python/beaker/beaker-1.7.0.ebuild b/dev-python/beaker/beaker-1.7.0.ebuild
deleted file mode 100644
index b609256ab2c7..000000000000
--- a/dev-python/beaker/beaker-1.7.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beaker/beaker-1.7.0.ebuild,v 1.1 2015/03/19 06:07:51 patrick Exp $
-
-EAPI=5
-
-# py3.3 unfit with some types
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="Beaker"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Session and Caching library with WSGI Middleware"
-HOMEPAGE="http://beaker.groovie.org/ http://pypi.python.org/pypi/Beaker"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}dev.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-# webtest-based tests are skipped when webtest is not installed
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}dev"
-
-python_prepare_all() {
- # Workaround for http://bugs.python.org/issue11276.
- sed -e "s/import anydbm/& as anydbm/;/import anydbm/a dbm = anydbm" \
- -i beaker/container.py || die
-
- distutils-r1_python_prepare_all
-}