summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-07 06:48:19 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-07 06:48:19 +0000
commit2bab905d8e1a80fc868f014a2a07310495eb364d (patch)
treeb7bb5187b34f708364fbd3e884699c5683a97a81 /dev-python
parentCleanup. (diff)
downloadgentoo-2-2bab905d8e1a80fc868f014a2a07310495eb364d.tar.gz
gentoo-2-2bab905d8e1a80fc868f014a2a07310495eb364d.tar.bz2
gentoo-2-2bab905d8e1a80fc868f014a2a07310495eb364d.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/biplist/ChangeLog7
-rw-r--r--dev-python/biplist/biplist-0.9.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/biplist/ChangeLog b/dev-python/biplist/ChangeLog
index d965c2d0a882..68816b138fb2 100644
--- a/dev-python/biplist/ChangeLog
+++ b/dev-python/biplist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/biplist
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.10 2015/06/06 20:04:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.11 2015/06/07 06:48:19 idella4 Exp $
+
+*biplist-0.9 (07 Jun 2015)
+
+ 07 Jun 2015; Ian Delaney <idella4@gentoo.org> +biplist-0.9.ebuild:
+ bump
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/biplist/biplist-0.9.ebuild b/dev-python/biplist/biplist-0.9.ebuild
new file mode 100644
index 000000000000..0ed63cd4d634
--- /dev/null
+++ b/dev-python/biplist/biplist-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.9.ebuild,v 1.1 2015/06/07 06:48:19 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A binary plist parser/generator for Python"
+HOMEPAGE="http://pypi.python.org/pypi/biplist/ https://github.com/wooster/biplist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
+
+python_test() {
+ # This failure still occurs, after 18 momths
+ # https://github.com/wooster/biplist/issues/8
+ nosetests || die "Tests failed under ${EPYTHON}"
+}