summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-10 06:19:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-10 06:19:20 +0000
commit3fa90160f34d4ef61aba4ee51dd1575bbc570844 (patch)
tree488e2ad999882136348c92929e182e21ebda3b29 /dev-python
parentCleanup. (diff)
downloadgentoo-2-3fa90160f34d4ef61aba4ee51dd1575bbc570844.tar.gz
gentoo-2-3fa90160f34d4ef61aba4ee51dd1575bbc570844.tar.bz2
gentoo-2-3fa90160f34d4ef61aba4ee51dd1575bbc570844.zip
bump; radical updating that goes with adding py3 pypy support and conversion -> distutils-r1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ptrace/ChangeLog10
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.2.ebuild38
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.3.ebuild45
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.4.ebuild45
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.5.ebuild45
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.7.ebuild36
6 files changed, 45 insertions, 174 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index f5465e2c6145..18625b65df9a 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.12 2014/01/07 06:58:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.13 2014/04/10 06:19:20 idella4 Exp $
+
+*python-ptrace-0.7 (10 Apr 2014)
+
+ 10 Apr 2014; Ian Delaney <idella4@gentoo.org> +python-ptrace-0.7.ebuild,
+ -python-ptrace-0.6.2.ebuild, -python-ptrace-0.6.3.ebuild,
+ -python-ptrace-0.6.4.ebuild, -python-ptrace-0.6.5.ebuild:
+ bump; radical updating that goes with adding py3 pypy support and conversion
+ -> distutils-r1
*python-ptrace-0.6.6 (07 Jan 2014)
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
deleted file mode 100644
index f609381a6f8c..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild,v 1.4 2010/12/26 15:30:10 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- epatch python3.0.patch
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild
deleted file mode 100644
index 203302fe1d26..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.3.ebuild,v 1.2 2011/11/22 21:43:27 neurogeek Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild
deleted file mode 100644
index 7a7f13ccf29f..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild,v 1.1 2012/03/09 09:24:15 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild
deleted file mode 100644
index c7c841dda737..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild,v 1.1 2013/06/13 03:08:20 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.7.ebuild b/dev-python/python-ptrace/python-ptrace-0.7.ebuild
new file mode 100644
index 000000000000..17cd0194c8b4
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.7.ebuild,v 1.1 2014/04/10 06:19:20 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+# Req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ echo "${EPYTHON}"
+ if python_is_python3; then
+ 2to3 -w ptrace
+ fi
+ "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}