summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-22 10:35:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-22 10:35:32 +0000
commit4196dde03e93ef44bf11efcf3b148a6a9596f608 (patch)
tree80e5379b7ce167f3fc13bc6a48aee27a299c7ce0 /dev-python
parentdrop using base.eclass, prune la, minor update (diff)
downloadgentoo-2-4196dde03e93ef44bf11efcf3b148a6a9596f608.tar.gz
gentoo-2-4196dde03e93ef44bf11efcf3b148a6a9596f608.tar.bz2
gentoo-2-4196dde03e93ef44bf11efcf3b148a6a9596f608.zip
bump; drop py2.6 pypy2_0
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webob/ChangeLog7
-rw-r--r--dev-python/webob/webob-1.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 19c3ca7fe29a..1d881cb07b62 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.87 2014/04/02 21:14:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.88 2014/05/22 10:35:32 idella4 Exp $
+
+*webob-1.4 (22 May 2014)
+
+ 22 May 2014; Ian Delaney <idella4@gentoo.org> +webob-1.4.ebuild:
+ bump; drop py2.6 pypy2_0
02 Apr 2014; Tim Harder <radhermit@gentoo.org> webob-1.3.1.ebuild:
Add python3_4 support.
diff --git a/dev-python/webob/webob-1.4.ebuild b/dev-python/webob/webob-1.4.ebuild
new file mode 100644
index 000000000000..c26ecba293ef
--- /dev/null
+++ b/dev-python/webob/webob-1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.4.ebuild,v 1.1 2014/05/22 10:35:32 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ nosetests -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}