summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-05 05:32:16 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-05 05:32:16 +0000
commit41b87cfd9ac929ae78394464066e4513a18bfd9c (patch)
treeee0974877dcf09b14b4a79a71a6dde060352e060 /dev-python
parentvanilla-4.1.4 + genpatches-4.1-7 + grsecurity-3.1-4.1.4-201508032312 (diff)
downloadgentoo-2-41b87cfd9ac929ae78394464066e4513a18bfd9c.tar.gz
gentoo-2-41b87cfd9ac929ae78394464066e4513a18bfd9c.tar.bz2
gentoo-2-41b87cfd9ac929ae78394464066e4513a18bfd9c.zip
bump; testsuite currently unworkable, test phase left restricted
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-nose/ChangeLog7
-rw-r--r--dev-python/django-nose/django-nose-1.4.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/django-nose/ChangeLog b/dev-python/django-nose/ChangeLog
index 6caac851bf63..d42c43745c1a 100644
--- a/dev-python/django-nose/ChangeLog
+++ b/dev-python/django-nose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django-nose
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-nose/ChangeLog,v 1.13 2015/07/28 05:28:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-nose/ChangeLog,v 1.14 2015/08/05 05:32:16 idella4 Exp $
+
+*django-nose-1.4.1 (05 Aug 2015)
+
+ 05 Aug 2015; Ian Delaney <idella4@gentoo.org> +django-nose-1.4.1.ebuild:
+ bump; testsuite currently unworkable, test phase left restricted
28 Jul 2015; Patrick Lauer <patrick@gentoo.org> django-nose-1.3.ebuild,
django-nose-1.4.ebuild:
diff --git a/dev-python/django-nose/django-nose-1.4.1.ebuild b/dev-python/django-nose/django-nose-1.4.1.ebuild
new file mode 100644
index 000000000000..35751830cf44
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-nose/django-nose-1.4.1.ebuild,v 1.1 2015/08/05 05:32:16 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # The testsuite currently broken See notes below
+
+RDEPEND=">=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? ( ${RDEPEND}
+# >=dev-python/south-0.7[${PYTHON_USEDEP}] )"
+# South currently doesn't support any versions of django in portage
+# that support python3. They are masked as is south which appears may be deprecated
+
+python_test() {
+ # https://github.com/django-nose/django-nose/issues/227
+ # Running tests by the bash script runtests.sh reveals a missing
+ # folder. Use of runtests.py works only for py2.7 due to
+ # south supporting only old versions of django.
+ # The testsuite has a massive rewrite set in the issue listed above.
+ ./runtests.sh
+# "${PYTHON}" testapp/runtests.py broken
+}