summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-12-19 20:42:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-12-19 20:42:42 +0000
commit5a22cbdf617c6387eefb9358e43a30e1980d1b96 (patch)
tree1a37f9a0b630db1de2b0a3b1bc9a56fee01f2ebd /dev-python
parentAdding SELinux fixes for the AF_UNIX patch; bug #72317. Also fixing security ... (diff)
downloadgentoo-2-5a22cbdf617c6387eefb9358e43a30e1980d1b96.tar.gz
gentoo-2-5a22cbdf617c6387eefb9358e43a30e1980d1b96.tar.bz2
gentoo-2-5a22cbdf617c6387eefb9358e43a30e1980d1b96.zip
debug support, minor fixes
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog5
-rw-r--r--dev-python/sip/sip-4.1.1.ebuild20
2 files changed, 15 insertions, 10 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index c1bd8e860ba6..b53705af8f29 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.52 2004/12/16 10:26:47 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.53 2004/12/19 20:42:42 carlo Exp $
+
+ 19 Dec 2004; Carsten Lohrke <carlo@gentoo.org> sip-4.1.1.ebuild:
+ debug support, minor fixes
16 Dec 2004; Dylan Carlson <absinthe@gentoo.org> sip-4.1.1.ebuild:
Stable on amd64.
diff --git a/dev-python/sip/sip-4.1.1.ebuild b/dev-python/sip/sip-4.1.1.ebuild
index 3261a629dcf8..7b6c20bf6dc0 100644
--- a/dev-python/sip/sip-4.1.1.ebuild
+++ b/dev-python/sip/sip-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.1.1.ebuild,v 1.5 2004/12/16 10:26:47 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.1.1.ebuild,v 1.6 2004/12/19 20:42:42 carlo Exp $
inherit distutils
@@ -14,7 +14,7 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc sparc ~alpha amd64 ~ppc64"
-IUSE="doc"
+IUSE="debug doc"
DEPEND="virtual/libc
x11-libs/qt
@@ -22,20 +22,22 @@ DEPEND="virtual/libc
src_compile(){
distutils_python_version
- python configure.py -l qt-mt \
- -b /usr/bin \
- -d /usr/lib/python${PYVER}/site-packages \
- -e /usr/include/python${PYVER} \
- "CXXFLAGS+=${CXXFLAGS}"
- emake || die
+
+ local myconf="-l qt-mt -b /usr/bin -d /usr/lib/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
+ emake || die "emake failed"
}
src_install() {
- einstall DESTDIR=${D} || die
+ make DESTDIR=${D} install || die "install failed"
dodoc ChangeLog LICENSE NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
}
pkg_postinst() {
+ echo ""
einfo "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
+ echo ""
}