summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-13 08:09:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-13 08:09:38 +0000
commit5ac17040b9c3f96a0bb97036b4c108c6c828ddab (patch)
treec04eb1350fafcd83586796cbae601468752f788d /dev-python
parentFix building with OpenSSL >= 1.0.0 wrt #328031 by Alec M. (diff)
downloadgentoo-2-5ac17040b9c3f96a0bb97036b4c108c6c828ddab.tar.gz
gentoo-2-5ac17040b9c3f96a0bb97036b4c108c6c828ddab.tar.bz2
gentoo-2-5ac17040b9c3f96a0bb97036b4c108c6c828ddab.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/sip-4.10.3.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index cbcd44380751..5ca011423676 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.167 2010/07/06 18:41:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.168 2010/07/13 08:09:38 hwoarang Exp $
+
+*sip-4.10.3 (13 Jul 2010)
+
+ 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +sip-4.10.3.ebuild:
+ Version bump
06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
sip-4.8.2.ebuild, sip-4.8.2-r1.ebuild, sip-4.9.3-r1.ebuild,
diff --git a/dev-python/sip/sip-4.10.3.ebuild b/dev-python/sip/sip-4.10.3.ebuild
new file mode 100644
index 000000000000..171d2ca6361b
--- /dev/null
+++ b/dev-python/sip/sip-4.10.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.3.ebuild,v 1.1 2010/07/13 08:09:38 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs
+
+MY_P=${P/_pre/-snapshot-}
+
+DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py
+ --bindir=${EPREFIX}/usr/bin
+ --destdir=${EPREFIX}$(python_get_sitedir)
+ --incdir=${EPREFIX}$(python_get_includedir)
+ --sipdir=${EPREFIX}/usr/share/sip
+ $(use debug && echo '--debug')
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
+ LFLAGS='${LDFLAGS}'
+ STRIP=true"
+ echo ${myconf}
+ eval ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+
+ dodoc NEWS || die
+
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+
+ ewarn 'When updating sip, you usually need to recompile packages that'
+ ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
+ ewarn 'app-portage/gentoolkit installed you can find these packages with'
+ ewarn '`equery d sip` and `equery d PyQt4`.'
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}