summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 13:40:54 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 13:40:54 +0000
commit5f7577e1ab8220ee38532b9c8f1b21742f6fba20 (patch)
treee12e140010d71be29865fbec8caedfaeddc41725 /dev-python
parentInclude razorqt-base/razorqt-notifications wrt #461366 (diff)
downloadgentoo-2-5f7577e1ab8220ee38532b9c8f1b21742f6fba20.tar.gz
gentoo-2-5f7577e1ab8220ee38532b9c8f1b21742f6fba20.tar.bz2
gentoo-2-5f7577e1ab8220ee38532b9c8f1b21742f6fba20.zip
Version bump, drop old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gst-python/ChangeLog8
-rw-r--r--dev-python/gst-python/gst-python-0.10.22.ebuild63
-rw-r--r--dev-python/gst-python/gst-python-1.2.1.ebuild58
3 files changed, 65 insertions, 64 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index 16a24bfeda7f..d836b7bb842e 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.130 2014/04/06 10:28:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.131 2014/05/31 13:40:54 pacho Exp $
+
+*gst-python-1.2.1 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +gst-python-1.2.1.ebuild,
+ -gst-python-0.10.22.ebuild:
+ Version bump, drop old
*gst-python-1.2.0 (06 Apr 2014)
diff --git a/dev-python/gst-python/gst-python-0.10.22.ebuild b/dev-python/gst-python/gst-python-0.10.22.ebuild
deleted file mode 100644
index 7007a03952f4..000000000000
--- a/dev-python/gst-python/gst-python-0.10.22.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.22.ebuild,v 1.13 2012/11/07 20:10:53 tetromino Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit autotools eutils python
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org/"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0.10"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="examples test"
-
-RDEPEND="dev-libs/libxml2
- >=dev-python/pygobject-2.28:2
- >=media-libs/gstreamer-0.10.32:0.10
- >=media-libs/gst-plugins-base-0.10.32:0.10"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? (
- media-plugins/gst-plugins-ogg:0.10
- media-plugins/gst-plugins-vorbis:0.10
- )" # tests a "audiotestsrc ! vorbisenc ! oggmux ! fakesink" pipeline
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
- python_clean_py-compile_files #396689
- AT_M4DIR="common/m4" eautoreconf
- python_src_prepare
-}
-
-src_install() {
- python_src_install
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-
- python_clean_installation_image
-}
-
-src_test() {
- LC_ALL="C" python_src_test
-}
-
-pkg_postinst() {
- python_mod_optimize pygst.py gst-0.10
-}
-
-pkg_postrm() {
- python_mod_cleanup pygst.py gst-0.10
-}
diff --git a/dev-python/gst-python/gst-python-1.2.1.ebuild b/dev-python/gst-python/gst-python-1.2.1.ebuild
new file mode 100644
index 000000000000..b6a4ed0bed31
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-1.2.1.ebuild,v 1.1 2014/05/31 13:40:54 pacho Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test" #examples , bug #506962
+
+RDEPEND="
+ dev-libs/libxml2
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.2:1.0
+ >=media-libs/gst-plugins-base-1.2:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# XXX: unittests are not ported to 1.0 yet.
+
+src_prepare() {
+ # Leave examples alone
+ sed -e 's/\(SUBDIRS = .*\)examples/\1/' \
+ -i Makefile.am Makefile.in || die
+
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+
+# if use examples; then
+# docinto examples
+# dodoc examples/*
+# fi
+}