summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-26 22:38:00 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-26 22:38:00 +0000
commit65d70173febc4afbbec25185ebe28f36d92a7b65 (patch)
tree00210178e55314cae1dc2457faadabd2ae52506e /dev-python
parentVersion bump with some cleanups. Dropped old versions. (diff)
downloadgentoo-2-65d70173febc4afbbec25185ebe28f36d92a7b65.tar.gz
gentoo-2-65d70173febc4afbbec25185ebe28f36d92a7b65.tar.bz2
gentoo-2-65d70173febc4afbbec25185ebe28f36d92a7b65.zip
Version bump. Dropped old versions.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qscintilla/ChangeLog12
-rw-r--r--dev-python/qscintilla/files/digest-qscintilla-1.7.13
-rw-r--r--dev-python/qscintilla/files/qscintilla-1.7.1.patch17
-rw-r--r--dev-python/qscintilla/qscintilla-1.7.1.ebuild71
4 files changed, 102 insertions, 1 deletions
diff --git a/dev-python/qscintilla/ChangeLog b/dev-python/qscintilla/ChangeLog
index 4d223df2bcf6..fcaf1f286aef 100644
--- a/dev-python/qscintilla/ChangeLog
+++ b/dev-python/qscintilla/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/qscintilla
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.66 2006/11/14 13:48:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.67 2006/12/26 22:38:00 dev-zero Exp $
+
+*qscintilla-1.7.1 (26 Dec 2006)
+
+ 26 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+ -files/qscintilla-1.6-sandbox.patch, +files/qscintilla-1.7.1.patch,
+ -files/qscintilla-1.7.patch, -files/qscintilla-1.60-sandbox.patch,
+ -files/qscintilla-1.61-sandbox.patch,
+ -files/qscintilla-1.65-sandbox.patch, -qscintilla-1.6.ebuild,
+ -qscintilla-1.7.ebuild, +qscintilla-1.7.1.ebuild:
+ Version bump. Dropped old versions.
*qscintilla-1.7 (14 Nov 2006)
diff --git a/dev-python/qscintilla/files/digest-qscintilla-1.7.1 b/dev-python/qscintilla/files/digest-qscintilla-1.7.1
new file mode 100644
index 000000000000..a062abe9a8dd
--- /dev/null
+++ b/dev-python/qscintilla/files/digest-qscintilla-1.7.1
@@ -0,0 +1,3 @@
+MD5 dfa047b45d4f09ae8d4a8a431ba88a5a QScintilla-1.71-gpl-1.7.1.tar.gz 1060119
+RMD160 ba85db98e552b388510df5d1f7e0e78f52856ed2 QScintilla-1.71-gpl-1.7.1.tar.gz 1060119
+SHA256 437e5fc6e5905f9aa7d0f4ea8eb41c96fcddf7ce3cb9b786066a315c5b9ff70c QScintilla-1.71-gpl-1.7.1.tar.gz 1060119
diff --git a/dev-python/qscintilla/files/qscintilla-1.7.1.patch b/dev-python/qscintilla/files/qscintilla-1.7.1.patch
new file mode 100644
index 000000000000..99eb91369f97
--- /dev/null
+++ b/dev-python/qscintilla/files/qscintilla-1.7.1.patch
@@ -0,0 +1,17 @@
+--- designer/designer.pro.orig 2006-11-14 08:35:36.000000000 -0500
++++ designer/designer.pro 2006-11-14 08:35:49.000000000 -0500
+@@ -3,10 +3,12 @@
+
+ TEMPLATE = lib
+ TARGET = qscintillaplugin
+-DESTDIR = $(QTDIR)/plugins/designer
++DESTDIR = .
+
+ CONFIG += qt warn_on release plugin
+
+ SOURCES += qscintillaplugin.cpp
+
+-LIBS += -lqscintilla
++LIBS += -L../qt -lqscintilla
++
++INCLUDEPATH += ../qt
diff --git a/dev-python/qscintilla/qscintilla-1.7.1.ebuild b/dev-python/qscintilla/qscintilla-1.7.1.ebuild
new file mode 100644
index 000000000000..38668678344c
--- /dev/null
+++ b/dev-python/qscintilla/qscintilla-1.7.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/qscintilla-1.7.1.ebuild,v 1.1 2006/12/26 22:38:00 dev-zero Exp $
+
+inherit eutils toolchain-funcs
+
+QSCINTILLA_MAJOR_VER="1"
+SCINTILLA_VER="1.71"
+MY_P="${PN/qs/QS}-${SCINTILLA_VER}-gpl-${PV}"
+MY_P=${MY_P/_pre/snapshot-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor class."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/qscintilla/"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/QScintilla/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/QScintilla1/${MY_P}.tar.gz"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="=x11-libs/qt-3*"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/qt
+ sed -i -e "s:DESTDIR = \$(QTDIR)/lib:DESTDIR = lib:" qscintilla.pro
+ echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> qscintilla.pro
+ ${QTDIR}/bin/qmake -o Makefile qscintilla.pro
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+
+ cd ${S}/designer
+ echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> designer.pro
+ ${QTDIR}/bin/qmake -o Makefile designer.pro
+}
+
+src_compile() {
+ cd ${S}/qt
+ make all staticlib CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "make failed"
+ cd ${S}/designer
+ dodir ${QTDIR}/plugins/designer
+ make
+}
+
+src_install() {
+ dodoc ChangeLog LICENSE NEWS README*
+ dodir ${ROOT}/usr/{include,$(get_libdir),share/qscintilla/translations}
+ cd ${S}/qt
+ cp qextscintilla*.h "${D}/usr/include"
+ cp qscintilla*.qm "${D}/usr/share/qscintilla/translations"
+ cp lib/libqscintilla.a* "${D}/usr/$(get_libdir)"
+ cp -d lib/libqscintilla.so.* "${D}/usr/$(get_libdir)"
+ dodir ${QTDIR}/translations/
+ for I in $(ls -1 qscintilla*.qm) ; do
+ dosym "/usr/share/qscintilla/translations/${I}" "${QTDIR}/translations/${I}"
+ done
+ if use doc ; then
+ dohtml ${S}/doc/html/*
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins ${S}/doc/Scintilla/*
+ fi
+ insinto ${QTDIR}/plugins/designer
+ insopts -m0755
+ doins ${S}/designer/libqscintillaplugin.so
+}