summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-03-15 12:18:05 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-03-15 12:18:05 +0000
commit6a9f70055ab815577a0a792538ba29805ac05d06 (patch)
tree5fb42b4dcb39c028f495d126546f6c82f5372129 /dev-python
parentmore multilib fixes (#76791) (diff)
downloadgentoo-2-6a9f70055ab815577a0a792538ba29805ac05d06.tar.gz
gentoo-2-6a9f70055ab815577a0a792538ba29805ac05d06.tar.bz2
gentoo-2-6a9f70055ab815577a0a792538ba29805ac05d06.zip
more multilib fixes
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/pygtk-2.4.1.ebuild10
-rw-r--r--dev-python/pygtk/pygtk-2.6.0.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index ab591968186c..4f6653be4460 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.75 2005/03/08 18:05:06 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.76 2005/03/15 12:18:05 liquidx Exp $
+
+ 15 Mar 2005; Alastair Tse <liquidx@gentoo.org> pygtk-2.4.1.ebuild,
+ pygtk-2.6.0.ebuild:
+ more multilib fixes
08 Mar 2005; Alastair Tse <liquidx@gentoo.org> pygtk-2.6.0.ebuild:
add python numeric dep
diff --git a/dev-python/pygtk/pygtk-2.4.1.ebuild b/dev-python/pygtk/pygtk-2.4.1.ebuild
index d91c17847548..18639bab0ab7 100644
--- a/dev-python/pygtk/pygtk-2.4.1.ebuild
+++ b/dev-python/pygtk/pygtk-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.4.1.ebuild,v 1.12 2005/03/08 13:39:50 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.4.1.ebuild,v 1.13 2005/03/15 12:18:05 liquidx Exp $
inherit gnome.org python flag-o-matic
@@ -66,7 +66,7 @@ src_test() {
pkg_postinst() {
python_version
- python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/lib/python${PYVER}/site-packages/gtk-2.0
+ python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
@@ -76,8 +76,8 @@ pkg_postrm() {
python_version
python_mod_cleanup /usr/share/pygtk/2.0/codegen
python_mod_cleanup
- rm -f ${ROOT}/usr/lib/python${PYVER}/site-packages/pygtk.{py,pth}
- alternatives_auto_makesym /usr/lib/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym /usr/lib/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ rm -f ${ROOT}/usr$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
}
diff --git a/dev-python/pygtk/pygtk-2.6.0.ebuild b/dev-python/pygtk/pygtk-2.6.0.ebuild
index b8b2921b22ee..d5ba8f1c17bb 100644
--- a/dev-python/pygtk/pygtk-2.6.0.ebuild
+++ b/dev-python/pygtk/pygtk-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.0.ebuild,v 1.2 2005/03/08 18:05:06 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.0.ebuild,v 1.3 2005/03/15 12:18:05 liquidx Exp $
inherit gnome.org python flag-o-matic
@@ -67,7 +67,7 @@ src_test() {
pkg_postinst() {
python_version
- python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/lib/python${PYVER}/site-packages/gtk-2.0
+ python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
@@ -77,7 +77,7 @@ pkg_postrm() {
python_version
python_mod_cleanup /usr/share/pygtk/2.0/codegen
python_mod_cleanup
- rm -f ${ROOT}/usr/lib/python${PYVER}/site-packages/pygtk.{py,pth}
- alternatives_auto_makesym /usr/lib/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym /usr/lib/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ rm -f ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
}