summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-05-15 21:09:34 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-05-15 21:09:34 +0000
commit7054bfe95f43d9b593e475625e9a48ecd61ab11d (patch)
tree598f2436552f4bcfea55d27b80001ca2ae656923 /dev-python
parentHouse cleaning removed older versions and unused patches (diff)
downloadgentoo-2-7054bfe95f43d9b593e475625e9a48ecd61ab11d.tar.gz
gentoo-2-7054bfe95f43d9b593e475625e9a48ecd61ab11d.tar.bz2
gentoo-2-7054bfe95f43d9b593e475625e9a48ecd61ab11d.zip
Added tk USE flag and pkg_setup to ensure python was built with tk
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/pylint-0.12.2.ebuild19
-rw-r--r--dev-python/pylint/pylint-0.13.1.ebuild17
3 files changed, 35 insertions, 7 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index c26a422a97e3..75fd44d15119 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.34 2007/03/05 02:59:11 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.35 2007/05/15 21:09:34 pythonhead Exp $
+
+ 15 May 2007; Rob Cakebread <pythonhead@gentoo.org> pylint-0.12.2.ebuild,
+ pylint-0.13.1.ebuild:
+ Added tk USE flag and pkg_setup to ensure python was built with tk
05 Mar 2007; Marius Mauch <genone@gentoo.org> pylint-0.12.1.ebuild,
pylint-0.12.2.ebuild, pylint-0.13.1.ebuild:
diff --git a/dev-python/pylint/pylint-0.12.2.ebuild b/dev-python/pylint/pylint-0.12.2.ebuild
index 0889b9ea4b31..a244a9ac33a2 100644
--- a/dev-python/pylint/pylint-0.12.2.ebuild
+++ b/dev-python/pylint/pylint-0.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.12.2.ebuild,v 1.3 2007/03/05 02:59:11 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.12.2.ebuild,v 1.4 2007/05/15 21:09:34 pythonhead Exp $
inherit distutils eutils
@@ -8,16 +8,28 @@ DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding sta
SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
HOMEPAGE="http://www.logilab.org/projects/pylint/"
-IUSE=""
+IUSE="tk"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
LICENSE="GPL-2"
DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
>=dev-python/logilab-common-0.21.0
- >=dev-python/astng-0.16.0"
+ >=dev-python/astng-0.16.0
+ tk? ( >=dev-lang/tk-8.4.9 )"
DOCS="doc/*.txt"
+
+pkg_setup() {
+ if use tk && ! built_with_use dev-lang/python tk; then
+ eerror "You have USE='tk' enabled."
+ eerror "Python has not been compiled with tkinter support."
+ eerror "Please re-emerge python with the 'tk' USE-flag set."
+ die "Missing USE-flag for dev-lang/python"
+ fi
+}
+
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -27,6 +39,7 @@ src_unpack() {
# Make pylint-gui print a gentoo-specific message if Tkinter is missing
epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
+
}
src_install() {
diff --git a/dev-python/pylint/pylint-0.13.1.ebuild b/dev-python/pylint/pylint-0.13.1.ebuild
index 471003b31880..44c5f5053e56 100644
--- a/dev-python/pylint/pylint-0.13.1.ebuild
+++ b/dev-python/pylint/pylint-0.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.13.1.ebuild,v 1.2 2007/03/05 02:59:11 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.13.1.ebuild,v 1.3 2007/05/15 21:09:34 pythonhead Exp $
inherit distutils eutils
@@ -8,16 +8,26 @@ DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding sta
SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
HOMEPAGE="http://www.logilab.org/projects/pylint/"
-IUSE=""
+IUSE="tk"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
LICENSE="GPL-2"
DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
>=dev-python/logilab-common-0.21.0
- >=dev-python/astng-0.17.0"
+ >=dev-python/astng-0.17.0
+ tk? ( >=dev-lang/tk-8.4.9 )"
DOCS="doc/*.txt"
+pkg_setup() {
+ if use tk && ! built_with_use dev-lang/python tk; then
+ eerror "You have USE='tk' enabled."
+ eerror "Python has not been compiled with tkinter support."
+ eerror "Please re-emerge python with the 'tk' USE-flag set."
+ die "Missing USE-flag for dev-lang/python"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -53,6 +63,7 @@ src_test() {
# These fail, have not been able to track down why.
rm rpythoninput/func_unsupported_protocol.py || die "rm failed"
+ rm func_test_rpython.py || die "rm failed"
PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
die "tests failed"
cd "${S}"