summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-19 14:27:23 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-19 14:27:23 +0000
commit92ce5025b7ab8285df64729b62811a17639c0e17 (patch)
tree332d388390b8f2894be7d292ce7b7b9a45b90bb4 /dev-python
parentrevbump; convert -> distutils-r1, rm old, clean old impls (diff)
downloadgentoo-2-92ce5025b7ab8285df64729b62811a17639c0e17.tar.gz
gentoo-2-92ce5025b7ab8285df64729b62811a17639c0e17.tar.bz2
gentoo-2-92ce5025b7ab8285df64729b62811a17639c0e17.zip
revbump; convert -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twistedsnmp/ChangeLog11
-rw-r--r--dev-python/twistedsnmp/twistedsnmp-0.3.13-r1.ebuild (renamed from dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild)40
2 files changed, 29 insertions, 22 deletions
diff --git a/dev-python/twistedsnmp/ChangeLog b/dev-python/twistedsnmp/ChangeLog
index 95f289e093e5..164e8a7984ad 100644
--- a/dev-python/twistedsnmp/ChangeLog
+++ b/dev-python/twistedsnmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twistedsnmp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.7 2013/08/03 09:45:50 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.8 2015/02/19 14:27:23 idella4 Exp $
+
+*twistedsnmp-0.3.13-r1 (19 Feb 2015)
+
+ 19 Feb 2015; Ian Delaney <idella4@gentoo.org> +twistedsnmp-0.3.13-r1.ebuild,
+ -twistedsnmp-0.3.13.ebuild:
+ revbump; convert -> distutils-r1, rm old
03 Aug 2013; Michał Górny <mgorny@gentoo.org> twistedsnmp-0.3.13.ebuild:
Move dev-python/twisted to dev-python/twisted-core.
@@ -32,4 +38,3 @@
+twistedsnmp-0.2.9.ebuild:
Initial Import
Bug 54871; Thanks to Mike C. Fletcher <mcfletch@rogers.com>
-
diff --git a/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild b/dev-python/twistedsnmp/twistedsnmp-0.3.13-r1.ebuild
index 6b41fbb0eae9..57107824e3ed 100644
--- a/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
+++ b/dev-python/twistedsnmp/twistedsnmp-0.3.13-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild,v 1.3 2013/08/03 09:45:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.13-r1.ebuild,v 1.1 2015/02/19 14:27:23 idella4 Exp $
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
+EAPI=5
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
MY_PN="TwistedSNMP"
MY_P="${MY_PN}-${PV}"
@@ -17,32 +19,32 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="examples test"
-RDEPEND="=dev-python/pysnmp-3*
- >=dev-python/twisted-core-1.3"
-DEPEND="${RDEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
+RDEPEND="=dev-python/pysnmp-3*[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-1.3[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )"
S="${WORKDIR}/${MY_P}"
-src_prepare() {
- distutils_src_prepare
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+python_prepare_all() {
# Disable broken test.
sed -e "s/test_tableGetWithStart/_&/" -i test/test_get.py || die "sed failed"
+ distutils-r1_python_prepare_all
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test.py
- }
- python_execute_function testing
+python_test() {
+ "${PYTHON}" test/test.py || die "tests failed"
}
src_install() {
- distutils_src_install
- dohtml doc/index.html
+ local HTML_DOCS=( doc/index.html )
+ use examples && local EXAMPLES=( doc/examples/. )
+ distutils-r1_src_install
insinto /usr/share/doc/${PF}/html/style/
doins doc/style/sitestyle.css
}