summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-25 03:28:41 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-25 03:28:41 +0000
commit96ba979c0b50f6cb3a6e30c9afdf328512adf854 (patch)
tree93e3c7219832ade10f58d6f3e272d274aabfa9cd /dev-python
parentConversion to multilib. Bug #510868 (diff)
downloadgentoo-2-96ba979c0b50f6cb3a6e30c9afdf328512adf854.tar.gz
gentoo-2-96ba979c0b50f6cb3a6e30c9afdf328512adf854.tar.bz2
gentoo-2-96ba979c0b50f6cb3a6e30c9afdf328512adf854.zip
unrestrict & upgrade test phase, add IUSE examples
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wtf-peewee/ChangeLog5
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild32
2 files changed, 25 insertions, 12 deletions
diff --git a/dev-python/wtf-peewee/ChangeLog b/dev-python/wtf-peewee/ChangeLog
index 7c8985f7cf62..4c7413e36207 100644
--- a/dev-python/wtf-peewee/ChangeLog
+++ b/dev-python/wtf-peewee/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/wtf-peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.5 2014/05/20 08:12:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.6 2014/05/25 03:28:41 idella4 Exp $
+
+ 25 May 2014; Ian Delaney <idella4@gentoo.org> wtf-peewee-0.2.1.ebuild:
+ unrestrict & upgrade test phase, add IUSE examples
*wtf-peewee-0.2.1 (20 May 2014)
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild
index 27372682f6dd..fe2aa01b112c 100644
--- a/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild
@@ -1,28 +1,38 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild,v 1.1 2014/05/20 08:12:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild,v 1.2 2014/05/25 03:28:41 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
-RESTRICT="test" # broken
-
DESCRIPTION="Small python ORM"
HOMEPAGE="https://github.com/coleifer/peewee/"
SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="examples test"
+
+RDEPEND="dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( "${RDEPEND}" )"
+
+python_prepare_all() {
+ # https://github.com/coleifer/peewee/issues/361
+ sed -e s':test_choices:_&:' \
+ -e s':test_null_form_saving:_&:' \
+ -i "${PN/\-/}"/tests.py || die
+ distutils-r1_python_prepare_all
+}
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/peewee[${PYTHON_USEDEP}]
- dev-python/wtforms[${PYTHON_USEDEP}]
- "
python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
+ "${PYTHON}" ./runtests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
}