summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-25 10:55:53 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-25 10:55:53 +0000
commita5988ffe94b2edb74e11f78a3ff41995d85a7908 (patch)
tree0e84d4d9e4ba2a5ef7271de96868e9005039e6fb /dev-python
parentStable for x86, wrt bug #473090 (diff)
downloadgentoo-2-a5988ffe94b2edb74e11f78a3ff41995d85a7908.tar.gz
gentoo-2-a5988ffe94b2edb74e11f78a3ff41995d85a7908.tar.bz2
gentoo-2-a5988ffe94b2edb74e11f78a3ff41995d85a7908.zip
New package, dep to jsonpickle, ebuild prepared by me
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxtogithub/ChangeLog9
-rw-r--r--dev-python/sphinxtogithub/Manifest3
-rw-r--r--dev-python/sphinxtogithub/metadata.xml8
-rw-r--r--dev-python/sphinxtogithub/sphinxtogithub-1.0.0.ebuild26
4 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinxtogithub/ChangeLog b/dev-python/sphinxtogithub/ChangeLog
new file mode 100644
index 000000000000..6b3b788cd173
--- /dev/null
+++ b/dev-python/sphinxtogithub/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/sphinxtogithub
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxtogithub/ChangeLog,v 1.1 2013/06/25 10:55:53 idella4 Exp $
+
+*sphinxtogithub-1.0.0 (25 Jun 2013)
+
+ 25 Jun 2013; Ian Delaney <idella4@gentoo.org> +metadata.xml,
+ +sphinxtogithub-1.0.0.ebuild:
+ New package, dep to jsonpickle, ebuild prepared by me
diff --git a/dev-python/sphinxtogithub/Manifest b/dev-python/sphinxtogithub/Manifest
new file mode 100644
index 000000000000..5ba9a8d90ab6
--- /dev/null
+++ b/dev-python/sphinxtogithub/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxtogithub-1.0.0.tar.gz 9872 SHA256 71e191b38defcfcff4acd918190a6322d8b7374fe84b97b6bc17d74c550c5759 SHA512 1eca486fc78715281b1e55fddabe2c161ca15d8b54981618de233e8eba9e14be575c5e3b6b1e4664186fce1414877d501c8f563c8771ff46c2d26ea96810450b WHIRLPOOL 0ac54064fd05e109505444fe9d1d3b8c12b7fa4b00dc5d6f7e713ede81a6ce6d723f2c983aabde5ed180467409234133ea88a4224bcc5248d7b33365c5b044a9
+EBUILD sphinxtogithub-1.0.0.ebuild 623 SHA256 bb36c28ff0ee837f77110234250c4eeb4be53b54f9befab2a12ce8d6b9a02fbb SHA512 2c54e7cf5f53912bacbf1f20a549dbcae1d3cee5e74f2b904fc70ef45518fafe1cddd03e7fdad33bbf2c59cd547529e192011d0284d171573783ab5136e2aad8 WHIRLPOOL 7a3c99bf66d52b1c74b08f5351ef409da6da8f020c458d6db54cf89e4d3fc954c3a720dd8e4d98044a4f941500bfd64cb0e0b568ab71596ef9e72ca8b6c92092
+MISC metadata.xml 237 SHA256 c5eb2f640a903ac82969888cb1d1a2dc99004bd59135575abc1c20724638487f SHA512 b3336e8a75a083aff4fdd3e9b91fb35da865be0ec2da8695a99cdf3f1bbe5b03741e7bc23ddcd072485268ebdc9df48dfa535ce4168cee619c42b8a1ca90a725 WHIRLPOOL d15e698f084567bdba21284b4140c9130f22e6732fd34cb91740ebb9115cbae962e61500a575847e1c52e5fb8de390d533770087e449fb72d7e16bec7c86316a
diff --git a/dev-python/sphinxtogithub/metadata.xml b/dev-python/sphinxtogithub/metadata.xml
new file mode 100644
index 000000000000..91eff68f917c
--- /dev/null
+++ b/dev-python/sphinxtogithub/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">sphinxtogithub</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxtogithub/sphinxtogithub-1.0.0.ebuild b/dev-python/sphinxtogithub/sphinxtogithub-1.0.0.ebuild
new file mode 100644
index 000000000000..865e076bd66e
--- /dev/null
+++ b/dev-python/sphinxtogithub/sphinxtogithub-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxtogithub/sphinxtogithub-1.0.0.ebuild,v 1.1 2013/06/25 10:55:53 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script for preparing the html output of Sphinx documentation for github pages"
+HOMEPAGE="http://github.com/michaeljones/sphinx-to-github/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+RDEPEND=">=dev-python/sphinx-1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}