summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-26 12:25:28 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-26 12:25:28 +0000
commita59befc27602d365f1db5b0549572c32dd4052de (patch)
tree0c207bf9c9b3ada41f8f32c8bea098fa1c690a6c /dev-python
parentEAPI 5. (diff)
downloadgentoo-2-a59befc27602d365f1db5b0549572c32dd4052de.tar.gz
gentoo-2-a59befc27602d365f1db5b0549572c32dd4052de.tar.bz2
gentoo-2-a59befc27602d365f1db5b0549572c32dd4052de.zip
fix the ebuild
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-pipeline/ChangeLog7
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.15.ebuild12
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index 39e6e012f55c..d082311b1dd0 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/django-pipeline
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.19 2013/09/13 21:32:14 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.20 2014/04/26 12:25:28 idella4 Exp $
+
+ 26 Apr 2014; Ian Delaney <idella4@gentoo.org> django-pipeline-1.3.15.ebuild:
+ fix the ebuild
13 Sep 2013; Michał Górny <mgorny@gentoo.org> django-pipeline-1.3.15.ebuild:
Use virtual/python-futures.
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
index fe435ffe418d..7723da91737b 100644
--- a/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild,v 1.3 2013/09/13 21:32:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild,v 1.4 2014/04/26 12:25:28 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -13,7 +13,6 @@ HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberd
# PyPi releases lack docs/ subdir:
# https://github.com/cyberdelia/django-pipeline/pull/254
SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -29,16 +28,15 @@ DEPEND="${RDEPEND}
test? (
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
+# As usual for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- cp -r tests "${BUILD_DIR}"/ || die
- PYTHONPATH=${BUILD_DIR}:${PYTHONPATH} \
- django-admin.py test --settings=tests.settings tests \
+ PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
|| die "Tests failed under ${EPYTHON}"
}