summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-27 08:37:34 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-27 08:37:34 +0000
commitad40f040c1bd1f5ceef96941c4b298e26af7b49f (patch)
tree9f12cdbc3c85fa741d7256e0f45d455bf9b8e0c1 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-ad40f040c1bd1f5ceef96941c4b298e26af7b49f.tar.gz
gentoo-2-ad40f040c1bd1f5ceef96941c4b298e26af7b49f.tar.bz2
gentoo-2-ad40f040c1bd1f5ceef96941c4b298e26af7b49f.zip
Version Bump; add test
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/asyncio/ChangeLog8
-rw-r--r--dev-python/asyncio/asyncio-3.4.2.ebuild6
-rw-r--r--dev-python/asyncio/asyncio-3.4.3.ebuild26
-rw-r--r--dev-python/asyncio/metadata.xml12
4 files changed, 42 insertions, 10 deletions
diff --git a/dev-python/asyncio/ChangeLog b/dev-python/asyncio/ChangeLog
index 34afd090a50f..6f3b6fe86265 100644
--- a/dev-python/asyncio/ChangeLog
+++ b/dev-python/asyncio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/asyncio
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asyncio/ChangeLog,v 1.5 2015/05/17 10:17:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asyncio/ChangeLog,v 1.6 2015/05/27 08:37:34 jlec Exp $
+
+*asyncio-3.4.3 (27 May 2015)
+
+ 27 May 2015; Justin Lecher <jlec@gentoo.org> +asyncio-3.4.3.ebuild,
+ asyncio-3.4.2.ebuild, metadata.xml:
+ Version Bump; add test
17 May 2015; Pacho Ramos <pacho@gentoo.org> asyncio-3.4.2.ebuild:
ppc keyword, bug #548938
diff --git a/dev-python/asyncio/asyncio-3.4.2.ebuild b/dev-python/asyncio/asyncio-3.4.2.ebuild
index b4bc93db76d7..0e7a84253961 100644
--- a/dev-python/asyncio/asyncio-3.4.2.ebuild
+++ b/dev-python/asyncio/asyncio-3.4.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asyncio/asyncio-3.4.2.ebuild,v 1.5 2015/05/17 10:17:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asyncio/asyncio-3.4.2.ebuild,v 1.6 2015/05/27 08:37:34 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_COMPAT=( python3_{3,4} )
inherit distutils-r1
DESCRIPTION="reference implementation of PEP 3156"
-HOMEPAGE="http://pypi.python.org/pypi/asyncio http://code.google.com/p/tulip/"
+HOMEPAGE="http://pypi.python.org/pypi/asyncio https://github.com/python/asyncio"
SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
diff --git a/dev-python/asyncio/asyncio-3.4.3.ebuild b/dev-python/asyncio/asyncio-3.4.3.ebuild
new file mode 100644
index 000000000000..bc166a2801ae
--- /dev/null
+++ b/dev-python/asyncio/asyncio-3.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asyncio/asyncio-3.4.3.ebuild,v 1.1 2015/05/27 08:37:34 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="reference implementation of PEP 3156"
+HOMEPAGE="http://pypi.python.org/pypi/asyncio https://github.com/python/asyncio"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} runtests.py || die
+ PYTHONASYNCIODEBUG=1 ${PYTHON} runtests.py || die
+}
diff --git a/dev-python/asyncio/metadata.xml b/dev-python/asyncio/metadata.xml
index 3f1bdd7f8195..f24997034796 100644
--- a/dev-python/asyncio/metadata.xml
+++ b/dev-python/asyncio/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<maintainer>
-<email>prometheanfire@gentoo.org</email>
-<name>Matthew Thode</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
reference implementation of PEP 3156
</longdescription>
</pkgmetadata>