summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-26 13:15:28 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-26 13:15:28 +0000
commitd1c08418bf1493e21a2ba3d0c5e5e230f4a51ca0 (patch)
tree9c3ba22af917b9bb1b1bdec1ce4166a59c37c32a /dev-python
parentVersion Bump (diff)
downloadgentoo-2-d1c08418bf1493e21a2ba3d0c5e5e230f4a51ca0.tar.gz
gentoo-2-d1c08418bf1493e21a2ba3d0c5e5e230f4a51ca0.tar.bz2
gentoo-2-d1c08418bf1493e21a2ba3d0c5e5e230f4a51ca0.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/openpyxl/ChangeLog7
-rw-r--r--dev-python/openpyxl/openpyxl-2.2.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/openpyxl/ChangeLog b/dev-python/openpyxl/ChangeLog
index 73b30a4b9ecb..4db3042387c8 100644
--- a/dev-python/openpyxl/ChangeLog
+++ b/dev-python/openpyxl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/openpyxl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/openpyxl/ChangeLog,v 1.14 2015/05/13 12:50:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/openpyxl/ChangeLog,v 1.15 2015/05/26 13:15:28 jlec Exp $
+
+*openpyxl-2.2.3 (26 May 2015)
+
+ 26 May 2015; Justin Lecher <jlec@gentoo.org> +openpyxl-2.2.3.ebuild:
+ Version Bump
*openpyxl-2.2.2 (13 May 2015)
*openpyxl-9999 (13 May 2015)
diff --git a/dev-python/openpyxl/openpyxl-2.2.3.ebuild b/dev-python/openpyxl/openpyxl-2.2.3.ebuild
new file mode 100644
index 000000000000..d2f8aea6e8a8
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/openpyxl/openpyxl-2.2.3.ebuild,v 1.1 2015/05/26 13:15:28 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="http://openpyxl.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/jdcal[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+# tests aren't contained in tarball
+RESTRICT="test"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}