summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-03 10:58:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-03 10:58:40 +0000
commited7a9325d87813d0e03607ebfdc1486c377531ce (patch)
treee523b5a90b7218ebb4853ce20d38fec1d3942aad /dev-python
parentReduced description length and keyword ~x86. (diff)
downloadgentoo-2-ed7a9325d87813d0e03607ebfdc1486c377531ce.tar.gz
gentoo-2-ed7a9325d87813d0e03607ebfdc1486c377531ce.tar.bz2
gentoo-2-ed7a9325d87813d0e03607ebfdc1486c377531ce.zip
Changed virtual/tetex to virtual/latex-base, bug #222501. Added building of pykpathsea and t1code and rearranged deps.
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyx/ChangeLog9
-rw-r--r--dev-python/pyx/pyx-0.10-r1.ebuild57
-rw-r--r--dev-python/pyx/pyx-0.10.ebuild4
-rw-r--r--dev-python/pyx/pyx-0.6.1.ebuild29
4 files changed, 67 insertions, 32 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index 1bf07d5b8076..882da6eda57f 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.22 2008/05/13 17:18:29 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.23 2008/09/03 10:58:40 bicatali Exp $
+
+*pyx-0.10-r1 (03 Sep 2008)
+
+ 03 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> -pyx-0.6.1.ebuild,
+ pyx-0.10.ebuild, +pyx-0.10-r1.ebuild:
+ Changed virtual/tetex to virtual/latex-base, bug #222501. Added building
+ of pykpathsea and t1code and rearranged deps.
13 May 2008; Ali Polatel <hawking@gentoo.org> pyx-0.10.ebuild:
Set VARTEXFONTS to avoid possible sandbox issues wrt TeX fonts. Use
diff --git a/dev-python/pyx/pyx-0.10-r1.ebuild b/dev-python/pyx/pyx-0.10-r1.ebuild
new file mode 100644
index 000000000000..8c5d2084cbfc
--- /dev/null
+++ b/dev-python/pyx/pyx-0.10-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10-r1.ebuild,v 1.1 2008/09/03 10:58:40 bicatali Exp $
+
+inherit distutils eutils
+
+MY_P=${P/pyx/PyX}
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ virtual/tex-base
+ doc? ( virtual/latex-base )"
+RDEPEND="virtual/python
+ virtual/tex-base"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGES INSTALL"
+
+src_unpack() {
+ distutils_src_unpack
+
+ epatch "${FILESDIR}"/${P}.patch
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+
+ sed -i -e 's/^texipc =.*/texipc = 1/' pyxrc || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # The manual is not currently done because it needs mkhowto
+ # that's not currently available on our python ebuild
+ insinto /usr/share/doc/${P}/
+ doins faq/pyxfaq.pdf
+ fi
+}
diff --git a/dev-python/pyx/pyx-0.10.ebuild b/dev-python/pyx/pyx-0.10.ebuild
index d0f588b57266..d80bacb0e5da 100644
--- a/dev-python/pyx/pyx-0.10.ebuild
+++ b/dev-python/pyx/pyx-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10.ebuild,v 1.4 2008/05/13 17:18:29 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10.ebuild,v 1.5 2008/09/03 10:58:40 bicatali Exp $
inherit distutils eutils
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86"
IUSE="doc"
DEPEND="virtual/python
- virtual/tetex"
+ virtual/latex-base"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
diff --git a/dev-python/pyx/pyx-0.6.1.ebuild b/dev-python/pyx/pyx-0.6.1.ebuild
deleted file mode 100644
index aa54f5272326..000000000000
--- a/dev-python/pyx/pyx-0.6.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.6.1.ebuild,v 1.5 2004/09/11 22:30:56 lucass Exp $
-
-IUSE=""
-
-inherit distutils
-
-MY_P=${P/pyx/PyX}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
-SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
-HOMEPAGE="http://pyx.sourceforge.net/"
-
-DEPEND=">=dev-lang/python-2.2
- virtual/tetex"
-
-SLOT="0"
-KEYWORDS="x86 ~ppc"
-LICENSE="GPL-2"
-
-src_install() {
- DOCS="manual/manual.ps"
- distutils_src_install
-
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
-}