summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-31 09:17:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-31 09:17:25 +0000
commitfab806082ecc68cee20bae2ef1f7648de20d46e1 (patch)
tree05d808fa560ceb4fc05e98318da969a7266f1603 /dev-python
parentRemove old (diff)
downloadgentoo-2-fab806082ecc68cee20bae2ef1f7648de20d46e1.tar.gz
gentoo-2-fab806082ecc68cee20bae2ef1f7648de20d46e1.tar.bz2
gentoo-2-fab806082ecc68cee20bae2ef1f7648de20d46e1.zip
bump; drop py2.6 add py3.4 pypy, add doc build, tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-cache/ChangeLog9
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.5.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/requests-cache/ChangeLog b/dev-python/requests-cache/ChangeLog
index 6d783322b44b..86225e5a4e29 100644
--- a/dev-python/requests-cache/ChangeLog
+++ b/dev-python/requests-cache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests-cache
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.7 2013/11/26 05:27:41 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/ChangeLog,v 1.8 2014/08/31 09:17:25 idella4 Exp $
+
+*requests-cache-0.4.5 (31 Aug 2014)
+
+ 31 Aug 2014; Ian Delaney <idella4@gentoo.org> +requests-cache-0.4.5.ebuild:
+ bump; drop py2.6 add py3.4 pypy, add doc build, tidy
*requests-cache-0.4.4 (26 Nov 2013)
diff --git a/dev-python/requests-cache/requests-cache-0.4.5.ebuild b/dev-python/requests-cache/requests-cache-0.4.5.ebuild
new file mode 100644
index 000000000000..2b459b0cf16d
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.4.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-cache/requests-cache-0.4.5.ebuild,v 1.1 2014/08/31 09:17:25 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.python.org/pypi/requests-cache"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/requests-1.1.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+