summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-21 08:53:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-21 08:53:09 +0000
commitfbc5e8d7987547f29083103a0a81fec036eb259c (patch)
tree8ee1190b622140bcde3d6fc7e37b10abf673f794 /dev-python
parentStable for amd64 wrt bug #512158 (diff)
downloadgentoo-2-fbc5e8d7987547f29083103a0a81fec036eb259c.tar.gz
gentoo-2-fbc5e8d7987547f29083103a0a81fec036eb259c.tar.bz2
gentoo-2-fbc5e8d7987547f29083103a0a81fec036eb259c.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libcloud/ChangeLog7
-rw-r--r--dev-python/libcloud/libcloud-0.15.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/libcloud/ChangeLog b/dev-python/libcloud/ChangeLog
index eec4584b68b7..460691656f49 100644
--- a/dev-python/libcloud/ChangeLog
+++ b/dev-python/libcloud/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libcloud
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.17 2014/07/14 04:38:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.18 2014/07/21 08:53:09 patrick Exp $
+
+*libcloud-0.15.1 (21 Jul 2014)
+
+ 21 Jul 2014; Patrick Lauer <patrick@gentoo.org> +libcloud-0.15.1.ebuild:
+ Bump
*libcloud-0.15.0 (14 Jul 2014)
diff --git a/dev-python/libcloud/libcloud-0.15.1.ebuild b/dev-python/libcloud/libcloud-0.15.1.ebuild
new file mode 100644
index 000000000000..2ff39c1ffe05
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.15.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.15.1.ebuild,v 1.1 2014/07/21 08:53:09 patrick Exp $
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}