summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-16 09:14:25 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-16 09:14:25 +0000
commitfcd29ca722877d2c2403d42c0a0e23f3be4acbe1 (patch)
tree11ccef7aad0d7d3bfc1f5f86c2466271bfa83e86 /dev-python
parentsci-chemistry/pymol: Backport fix for stereo flickering (diff)
downloadgentoo-2-fcd29ca722877d2c2403d42c0a0e23f3be4acbe1.tar.gz
gentoo-2-fcd29ca722877d2c2403d42c0a0e23f3be4acbe1.tar.bz2
gentoo-2-fcd29ca722877d2c2403d42c0a0e23f3be4acbe1.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygit2/ChangeLog7
-rw-r--r--dev-python/pygit2/pygit2-0.19.0.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index 12766c9e63c9..967a3804dffc 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.17 2013/04/21 06:28:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.18 2013/07/16 09:14:25 radhermit Exp $
+
+*pygit2-0.19.0 (16 Jul 2013)
+
+ 16 Jul 2013; Tim Harder <radhermit@gentoo.org> +pygit2-0.19.0.ebuild:
+ Version bump.
*pygit2-0.18.1 (21 Apr 2013)
diff --git a/dev-python/pygit2/pygit2-0.19.0.ebuild b/dev-python/pygit2/pygit2-0.19.0.ebuild
new file mode 100644
index 000000000000..b599eb7cc306
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.19.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.19.0.ebuild,v 1.1 2013/07/16 09:14:25 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}