summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-07-04 00:04:15 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-07-04 00:04:15 +0000
commit4365586aca9f81feb7851c2b7faaf4f53f3151e7 (patch)
treee8f2e447090e803a8566b463b3a3a0b612a1b6d2 /dev-qt
parentApply various patches wrt bugs #491226, #503880, #507124, and #514968. (diff)
downloadgentoo-2-4365586aca9f81feb7851c2b7faaf4f53f3151e7.tar.gz
gentoo-2-4365586aca9f81feb7851c2b7faaf4f53f3151e7.tar.bz2
gentoo-2-4365586aca9f81feb7851c2b7faaf4f53f3151e7.zip
Backport patch to fix build with media-libs/jpeg-9 (bug 480182).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtgui/ChangeLog6
-rw-r--r--dev-qt/qtgui/files/qtgui-4.8.5-libjpeg-9.patch84
-rw-r--r--dev-qt/qtgui/qtgui-4.8.5-r3.ebuild3
3 files changed, 91 insertions, 2 deletions
diff --git a/dev-qt/qtgui/ChangeLog b/dev-qt/qtgui/ChangeLog
index 750d9044308e..0c1660178ac5 100644
--- a/dev-qt/qtgui/ChangeLog
+++ b/dev-qt/qtgui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-qt/qtgui
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/ChangeLog,v 1.34 2014/07/03 23:20:26 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/ChangeLog,v 1.35 2014/07/04 00:04:15 pesa Exp $
+
+ 04 Jul 2014; Davide Pesavento <pesa@gentoo.org>
+ +files/qtgui-4.8.5-libjpeg-9.patch, qtgui-4.8.5-r3.ebuild:
+ Backport patch to fix build with media-libs/jpeg-9 (bug 480182).
*qtgui-4.8.5-r3 (03 Jul 2014)
diff --git a/dev-qt/qtgui/files/qtgui-4.8.5-libjpeg-9.patch b/dev-qt/qtgui/files/qtgui-4.8.5-libjpeg-9.patch
new file mode 100644
index 000000000000..47d35e232499
--- /dev/null
+++ b/dev-qt/qtgui/files/qtgui-4.8.5-libjpeg-9.patch
@@ -0,0 +1,84 @@
+From 2a9ea11f4dea51f9e75036aab8e7a23f0eb4bd1f Mon Sep 17 00:00:00 2001
+From: aavit <eirik.aavitsland@digia.com>
+Date: Tue, 10 Sep 2013 11:46:51 +0200
+Subject: Compilation fix for libjpeg release 9
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In the latest libjpeg version, the "boolean" type is changed so that
+true and false no longer can be used instead of TRUE and FALSE.
+
+Also, purge some ancient code remains meant to support a now defunct
+OS´s idea about the boolean type.
+
+Task-number: QTBUG-33166
+Change-Id: Iebbdf300cfdc22775954de65f985358424ed2b49
+Reviewed-by: Gunnar Sletta <gunnar.sletta@digia.com>
+(cherry picked from qtbase/fad6aa619bf6eb048821a58065433f6b598c10e4)
+---
+ src/gui/image/qjpeghandler.cpp | 27 +++++----------------------
+ 1 file changed, 5 insertions(+), 22 deletions(-)
+
+diff --git a/src/gui/image/qjpeghandler.cpp b/src/gui/image/qjpeghandler.cpp
+index a8700b7..ba5c469 100644
+--- a/src/gui/image/qjpeghandler.cpp
++++ b/src/gui/image/qjpeghandler.cpp
+@@ -157,11 +157,7 @@ static boolean qt_fill_input_buffer(j_decompress_ptr cinfo)
+ } else {
+ src->bytes_in_buffer = num_read;
+ }
+-#if defined(Q_OS_UNIXWARE)
+- return B_TRUE;
+-#else
+- return true;
+-#endif
++ return TRUE;
+ }
+
+ static void qt_skip_input_data(j_decompress_ptr cinfo, long num_bytes)
+@@ -489,11 +485,7 @@ static boolean qt_empty_output_buffer(j_compress_ptr cinfo)
+ dest->next_output_byte = dest->buffer;
+ dest->free_in_buffer = max_buf;
+
+-#if defined(Q_OS_UNIXWARE)
+- return B_TRUE;
+-#else
+- return true;
+-#endif
++ return TRUE;
+ }
+
+ static void qt_term_destination(j_compress_ptr cinfo)
+@@ -584,13 +576,8 @@ static bool write_jpeg_image(const QImage &image, QIODevice *device, int sourceQ
+
+
+ int quality = sourceQuality >= 0 ? qMin(sourceQuality,100) : 75;
+-#if defined(Q_OS_UNIXWARE)
+- jpeg_set_quality(&cinfo, quality, B_TRUE /* limit to baseline-JPEG values */);
+- jpeg_start_compress(&cinfo, B_TRUE);
+-#else
+- jpeg_set_quality(&cinfo, quality, true /* limit to baseline-JPEG values */);
+- jpeg_start_compress(&cinfo, true);
+-#endif
++ jpeg_set_quality(&cinfo, quality, TRUE /* limit to baseline-JPEG values */);
++ jpeg_start_compress(&cinfo, TRUE);
+
+ row_pointer[0] = new uchar[cinfo.image_width*cinfo.input_components];
+ int w = cinfo.image_width;
+@@ -751,11 +738,7 @@ bool QJpegHandlerPrivate::readJpegHeader(QIODevice *device)
+ err.error_exit = my_error_exit;
+
+ if (!setjmp(err.setjmp_buffer)) {
+- #if defined(Q_OS_UNIXWARE)
+- (void) jpeg_read_header(&info, B_TRUE);
+- #else
+- (void) jpeg_read_header(&info, true);
+- #endif
++ (void) jpeg_read_header(&info, TRUE);
+
+ int width = 0;
+ int height = 0;
+--
+2.0.0
+
diff --git a/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild b/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild
index 052923c3c690..7779b455bcf1 100644
--- a/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild
+++ b/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild,v 1.1 2014/07/03 23:20:26 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtgui/qtgui-4.8.5-r3.ebuild,v 1.2 2014/07/04 00:04:15 pesa Exp $
EAPI=5
@@ -74,6 +74,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.8.5-disable-gtk-theme-check.patch" # bug 491226
"${FILESDIR}/${PN}-4.8.5-dont-crash-on-broken-GIF-images.patch" # bug 508984
"${FILESDIR}/${PN}-4.8.5-keyboard-shortcuts.patch" # bug 477796
+ "${FILESDIR}/${PN}-4.8.5-libjpeg-9.patch" # bug 480182
"${FILESDIR}/${PN}-4.8.5-qclipboard-delay.patch" # bug 514968
)