summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-01-26 17:54:24 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-01-26 17:54:24 +0000
commit8f773631a08f9f6439680b3bf518a75b78891bab (patch)
tree0d9cc0635cb24a34e75b9cd001de8a78e3ea25a4 /dev-qt
parentCleanup. (diff)
downloadgentoo-2-8f773631a08f9f6439680b3bf518a75b78891bab.tar.gz
gentoo-2-8f773631a08f9f6439680b3bf518a75b78891bab.tar.bz2
gentoo-2-8f773631a08f9f6439680b3bf518a75b78891bab.zip
Cleanup.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtdeclarative/ChangeLog6
-rw-r--r--dev-qt/qtdeclarative/metadata.xml3
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-4.8.4.ebuild77
3 files changed, 6 insertions, 80 deletions
diff --git a/dev-qt/qtdeclarative/ChangeLog b/dev-qt/qtdeclarative/ChangeLog
index edda031cf60c..04f4e22c87dc 100644
--- a/dev-qt/qtdeclarative/ChangeLog
+++ b/dev-qt/qtdeclarative/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-qt/qtdeclarative
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/ChangeLog,v 1.12 2014/01/26 11:55:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/ChangeLog,v 1.13 2014/01/26 17:54:24 pesa Exp $
+
+ 26 Jan 2014; Davide Pesavento <pesa@gentoo.org> -qtdeclarative-4.8.4.ebuild,
+ metadata.xml:
+ Cleanup.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> qtdeclarative-4.8.5.ebuild:
Stable for ia64, wrt bug #494728
diff --git a/dev-qt/qtdeclarative/metadata.xml b/dev-qt/qtdeclarative/metadata.xml
index da493d03e67c..082a7f8f093f 100644
--- a/dev-qt/qtdeclarative/metadata.xml
+++ b/dev-qt/qtdeclarative/metadata.xml
@@ -3,9 +3,8 @@
<pkgmetadata>
<herd>qt</herd>
<use>
- <flag name="c++0x">Build Qt using the C++11 standard</flag>
<flag name="exceptions">Add support for exceptions - like catching them
- inside the event loop (recommended by Nokia)</flag>
+ inside the event loop (recommended by upstream)</flag>
<flag name="qt3support">Enable the Qt3Support libraries for Qt4. Note that
this does not mean you can compile pure Qt3 programs with Qt4.</flag>
<flag name="webkit">Build the WebView QML component</flag>
diff --git a/dev-qt/qtdeclarative/qtdeclarative-4.8.4.ebuild b/dev-qt/qtdeclarative/qtdeclarative-4.8.4.ebuild
deleted file mode 100644
index 1a63e3b2c0c8..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-4.8.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/qtdeclarative-4.8.4.ebuild,v 1.1 2013/03/02 15:26:48 yngwin Exp $
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The Declarative module for the Qt toolkit"
-SLOT="4"
-if [[ ${QT4_BUILD_TYPE} == live ]]; then
- KEYWORDS=""
-else
- KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-fi
-IUSE="+accessibility qt3support webkit"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}[aqua=,debug=,qt3support=]
- ~dev-qt/qtgui-${PV}[accessibility=,aqua=,debug=,qt3support=]
- ~dev-qt/qtopengl-${PV}[aqua=,debug=,qt3support=]
- ~dev-qt/qtscript-${PV}[aqua=,debug=]
- ~dev-qt/qtsql-${PV}[aqua=,debug=,qt3support=]
- ~dev-qt/qtsvg-${PV}[accessibility=,aqua=,debug=]
- ~dev-qt/qtxmlpatterns-${PV}[aqua=,debug=]
- qt3support? ( ~dev-qt/qt3support-${PV}[accessibility=,aqua=,debug=] )
- webkit? ( ~dev-qt/qtwebkit-${PV}[aqua=,debug=] )
-"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/declarative
- src/imports
- src/plugins/qmltooling
- tools/designer/src/plugins/qdeclarativeview
- tools/qml
- tools/qmlplugindump"
-
- if use webkit; then
- QT4_TARGET_DIRECTORIES+=" src/3rdparty/webkit/Source/WebKit/qt/declarative"
- fi
-
- QT4_EXTRACT_DIRECTORIES="
- include
- src
- tools
- translations"
-
- QCONFIG_ADD="declarative"
- QCONFIG_DEFINE="QT_DECLARATIVE"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -declarative -no-gtkstyle
- $(qt_use accessibility)
- $(qt_use qt3support)
- $(qt_use webkit)"
- qt4-build_src_configure
-}
-
-src_install() {
- qt4-build_src_install
-
- # install private headers
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
- insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
- # ran for the 2nd time, need it for the updated headers
- fix_includes
- else
- insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
- fi
- find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} +
-}