summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-01 07:06:15 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-01 07:06:15 +0000
commit8a6402fa220e83c18ef0f96afb53fe7d83372cf0 (patch)
treef21557c2ddba2a241624b7bec3681a3cbb51b1b9 /dev-ruby/actionmailer
parentVersion bump for bug 418481. (diff)
downloadgentoo-2-8a6402fa220e83c18ef0f96afb53fe7d83372cf0.tar.gz
gentoo-2-8a6402fa220e83c18ef0f96afb53fe7d83372cf0.tar.bz2
gentoo-2-8a6402fa220e83c18ef0f96afb53fe7d83372cf0.zip
Version bump for bug 418481.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.5.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 607d518d6f72..5955e68ba428 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.187 2012/06/01 06:09:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.188 2012/06/01 07:06:15 graaff Exp $
+
+*actionmailer-3.2.5 (01 Jun 2012)
+
+ 01 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.5.ebuild:
+ Version bump for bug 418481.
01 Jun 2012; Hans de Graaff <graaff@gentoo.org> -actionmailer-3.0.10.ebuild,
-actionmailer-3.0.11.ebuild, -actionmailer-3.0.11-r2.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.5.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.5.ebuild
new file mode 100644
index 000000000000..58c517517e5a
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.5.ebuild,v 1.1 2012/06/01 07:06:15 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.4.4"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}