summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-20 10:06:40 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-20 10:06:40 +0000
commitc30c6ad7ac17ee40e165aeb78ee1a4e091043a87 (patch)
tree25fcd8ba38089f783eb5405fa6f8ce88b3a26edb /dev-ruby/actionmailer
parentmove to EAPI=4, byte compile python code, #398625 (diff)
downloadgentoo-2-c30c6ad7ac17ee40e165aeb78ee1a4e091043a87.tar.gz
gentoo-2-c30c6ad7ac17ee40e165aeb78ee1a4e091043a87.tar.bz2
gentoo-2-c30c6ad7ac17ee40e165aeb78ee1a4e091043a87.zip
Backport fix for hiding the simple_format TextHelper in email templates.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog10
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.11-r1.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index e431a8f4bd9d..654114f9e5a5 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.177 2011/12/31 20:39:30 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.178 2012/01/20 10:06:40 graaff Exp $
+
+*actionmailer-3.0.11-r1 (20 Jan 2012)
+
+ 20 Jan 2012; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-3.0.11-r1.ebuild:
+ Backport fix for hiding the simple_format TextHelper in email templates.
31 Dec 2011; Fabian Groffen <grobian@gentoo.org> actionmailer-3.1.3.ebuild:
Add Prefix keywords, bug #396547
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.11-r1.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.11-r1.ebuild
new file mode 100644
index 000000000000..dea1adadc20b
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.11-r1.ebuild,v 1.1 2012/01/20 10:06:40 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.19"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Rename private method to avoid conflict with the simple_format
+ # TextHelper. Already fixed in Rails 3.1.
+ sed -i -e 's/simple_format/format_paragraph/' lib/action_mailer/mail_helper.rb || die
+}