summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 07:26:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 07:26:14 +0000
commit12e48a708bea36b68a25c9870386d5c7a8f73720 (patch)
tree97564827ddc796f1c51237e1e234800920ae9437 /dev-ruby/activeresource
parentVersion bump for Rails 3.0.10 (diff)
downloadgentoo-2-12e48a708bea36b68a25c9870386d5c7a8f73720.tar.gz
gentoo-2-12e48a708bea36b68a25c9870386d5c7a8f73720.tar.bz2
gentoo-2-12e48a708bea36b68a25c9870386d5c7a8f73720.zip
Version bump for Rails 3.0.10
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.10.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 26f8201e8174..f8167e632146 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.95 2011/09/09 07:51:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.96 2011/09/28 07:26:14 graaff Exp $
+
+*activeresource-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org>
activeresource-3.0.9.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-3.0.10.ebuild b/dev-ruby/activeresource/activeresource-3.0.10.ebuild
new file mode 100644
index 000000000000..d1ac0c1da025
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.10.ebuild,v 1.1 2011/09/28 07:26:14 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}