summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 19:59:54 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 19:59:54 +0000
commit2f5ec6e2c15683ced5af97f6b8bdb0df9ec991e8 (patch)
tree8b3bb038704f61174175d6b3e38d3537384e4976 /dev-ruby/activesupport
parentVersion bump for Rails 4.0.5, security bug 509706. (diff)
downloadgentoo-2-2f5ec6e2c15683ced5af97f6b8bdb0df9ec991e8.tar.gz
gentoo-2-2f5ec6e2c15683ced5af97f6b8bdb0df9ec991e8.tar.bz2
gentoo-2-2f5ec6e2c15683ced5af97f6b8bdb0df9ec991e8.zip
Version bump for Rails 4.1.1, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-4.1.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 0b29d63eb9ed..ff8fa647ffd5 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.255 2014/05/06 19:29:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.256 2014/05/06 19:59:54 graaff Exp $
+
+*activesupport-4.1.1 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +activesupport-4.1.1.ebuild:
+ Version bump for Rails 4.1.1, security bug 509706.
*activesupport-4.0.5 (06 May 2014)
diff --git a/dev-ruby/activesupport/activesupport-4.1.1.ebuild b/dev-ruby/activesupport/activesupport-4.1.1.ebuild
new file mode 100644
index 000000000000..5104ff667271
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.1.1.ebuild,v 1.1 2014/05/06 19:59:54 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.1:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}