summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 13:15:56 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 13:15:56 +0000
commitf3e76c230ff1a89ed76147e27ac039fd87275c99 (patch)
tree3709c27ec960fecdf1e7445fce44f27349a08ef2 /dev-ruby/activesupport
parentRemove obsolete sed commands. (diff)
downloadgentoo-2-f3e76c230ff1a89ed76147e27ac039fd87275c99.tar.gz
gentoo-2-f3e76c230ff1a89ed76147e27ac039fd87275c99.tar.bz2
gentoo-2-f3e76c230ff1a89ed76147e27ac039fd87275c99.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.12.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 54233fe93832..8fa2d76f0f9f 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.221 2013/03/30 09:31:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.222 2013/03/30 13:15:56 graaff Exp $
+
+*activesupport-3.1.12 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-3.1.12.ebuild:
+ Version bump for security bug 462452.
*activesupport-2.3.18 (30 Mar 2013)
diff --git a/dev-ruby/activesupport/activesupport-3.1.12.ebuild b/dev-ruby/activesupport/activesupport-3.1.12.ebuild
new file mode 100644
index 000000000000..d2690d0d93b4
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.1.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.12.ebuild,v 1.1 2013/03/30 13:15:56 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}