summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-23 07:18:47 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-23 07:18:47 +0000
commit1fda496dcc39c1f1a1a117df9972d61da2cca467 (patch)
treeebb01dfc0ff32414b02378f2aecb786b2c5980cd /dev-ruby/addressable
parentVersion bump. (diff)
downloadgentoo-2-1fda496dcc39c1f1a1a117df9972d61da2cca467.tar.gz
gentoo-2-1fda496dcc39c1f1a1a117df9972d61da2cca467.tar.bz2
gentoo-2-1fda496dcc39c1f1a1a117df9972d61da2cca467.zip
Version bump.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/ChangeLog7
-rw-r--r--dev-ruby/addressable/addressable-2.3.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index 950fc7da275b..89deb7e2a36c 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.27 2013/01/01 09:04:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.28 2013/02/23 07:18:47 graaff Exp $
+
+*addressable-2.3.3 (23 Feb 2013)
+
+ 23 Feb 2013; Hans de Graaff <graaff@gentoo.org> +addressable-2.3.3.ebuild:
+ Version bump.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> addressable-2.3.2.ebuild:
Stable for x86, wrt bug #448672
diff --git a/dev-ruby/addressable/addressable-2.3.3.ebuild b/dev-ruby/addressable/addressable-2.3.3.ebuild
new file mode 100644
index 000000000000..a263e87055b6
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.3.3.ebuild,v 1.1 2013/02/23 07:18:47 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+}